Archived

This topic is now archived and is closed to further replies.

Guest Biffo

Saitek Throttle quadrant

Recommended Posts

Hi, I am just starting in flight sims and have just bought the Saitek Pro Yoke with throttle quadrant. Have plugged it in for my first ever use of Microsoft X flight Sim and the yoke works fine but the throttle quad doesnt. I just want to use one of the levers as a throttle for a Cessna 172 but none of the levers work. The green light on the quadrant is on and I have checked that the plug is in ok but so far no luck when operating the levers. I had a look in the FS controls set up to see if there was anything in there to adjust but nothing seems to work. I downloaded the latest drivers for the yoke but these drivers have no options or setting for the quadrant in them. I have a PC running XP with 4g of ram and a 2.8 pentium dual processor.Anyone help with this?Thanks in advance,cheers,Biffo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had this product once, sold it.Anyway, to get it working, I also had troubles. Finally, I set it up over FSUIPC.I can't help you a lot now, since neither my FS is install, nor I have my own puter...but, in assignments menu, there are different controllers - like, your yoke, then your keyboard etc... You have to check each and one of those, delete all yoke/TQ assignments there are, restart FS many times, because they will appear again and again... keep deleting until everything is gone (both slew and normal, and for each controller).After that set up your controllers manually. Should work that way.That all, is, provided your Saitek yoke incl. TQ is recognized in FS. If not, check game controllers in Control Panel - should be there with all its settings.

Share this post


Link to post
Share on other sites

Hi Word Not Allowed,Thanks for your input, as i am new to this I am not sure how to set up the yoke manually, can anyone help with that?Again, Thanks in advance.Cheers,Biffo

Share this post


Link to post
Share on other sites

Hi Crewcut, Thanks for your help, I have sent the throttle back to the suppliers to get a new one in case it was a hardware problem. When I get the replacement I will follow your protocol to set it up. Appreciate your input!Cheers,Biffo

Share this post


Link to post
Share on other sites
Hi Crewcut, Thanks for your help, I have sent the throttle back to the suppliers to get a new one in case it was a hardware problem. When I get the replacement I will follow your protocol to set it up. Appreciate your input!Cheers,Biffo
Hijust to let u know that the replacement throttle worked straight out of the box. Must have been a hardware prob.Thanks for the help with thus,Biffo

Share this post


Link to post
Share on other sites