Sign in to follow this  
Followers 0
Guest Anubis

Th ENB Series mod for FSX...

8 posts in this topic

Hello All,Has anyone experience with the ENB Series mod? From what I can read, it should be a quite useful utility that can be used to enhance FSX with bloom effects without fps loss... However when I tried it on my rig I got a massive fps loss and artifacts (black vertical stripes) on the screen. If you have a working version, would you be so kind to point out the source to download it? The problem seems to be an high degree of configuration of this tool so there are tons of different versions and distributions.Thanks for any hint,Paolo

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Paolo,Mark is the one that got me to using the ENB module and I think he just emailed his copy vs me going to look for itBut it should be ver 0.075 (or 0.75) and here are the relevant sections that most everyone tweaks as I currently have them.[bLOOM]BloomPowerDay=4BloomFadeTime=500BloomConstantDay=0BloomQuality=1BloomScreenLevelDay=40BloomCurveDay=0BloomPowerNight=20BloomConstantNight=2BloomCurveNight=0BloomScreenLevelNight=30BloomAdaptationScreenLevel=40BloomAdaptationMultiplier=50BloomAllowOversaturation=1BloomMaxLimit=75and[colorCORRECTION]ScreenLevelDay=100DarkeningAmountDay=5GammaCurveDay=2ColorSaturationDay=2ScreenLevelNight=2DarkeningAmountNight=-10GammaCurveNight=2ColorSaturationNight=2UsePaletteTexture=0The night settings give me just enough light after dark to keep from running into a mountain. I may change things again someday.Since some photoreal terrain seems to be quite dark, instead of fussing with the ENB to brighten it, I tried adjusting my SCREEN brightness from the default setting of 50% to 70% and I like it a lot better. It's certainly easier than reconfiguring the ENB parameters.I LIKE what it does for the sim and see NO fps hit at all using my normal locked at 30fps.Loyd

0

Share this post


Link to post
Share on other sites

Hi Loyd,Thanks for the answer, I will have a look. The section you mentioned is about adjusting color and luminosity, however right now I am stuck in fps problems which I need to address first. The version of the software is the same.Paolo

0

Share this post


Link to post
Share on other sites

I use this:PROXY]EnableProxyLibrary=0InitProxyFunctions=0ProxyLibrary=[GLOBAL]UseEffect=1AlternativeDepth=1AllowAntialias=1BugFixMode=0SkipShaderOptimization=0QuadVertexBuffer=0EnableShaders_3_0=1UseMRTRendering=0AdditionalConfigFile=enbseries2.ini[EFFECT]EnableBloom=1EnableOcclusion=0EnableReflection=0EnableMotionBlur=0EnableWater=0EnableShadow=0DepthBias=0EnableDepthOfField=0[iNPUT]KeyUseEffect=123KeyBloom=120KeyOcclusion=121KeyReflection=122KeyCombination=16KeyScreenshot=44KeyShadow=119KeyWater=118KeyShowFPS=106[REFLECTION]ReflectionPower=25ChromePower=25UseCurrentFrameReflection=1ReflectionQuality=1ReflectionSourceSpecular=50ReflectionSourceTFactor=50UseAdditiveReflection=1ReflectionDepthBias=0UseLowResReflection=1ReflectionSinglePass=1UseEnvBump=0EnvBumpAmount=100EnvBumpOffset=100ReflectionFlip=0[bLOOM]BloomPowerDay=5BloomFadeTime=200BloomConstantDay=1BloomQuality=0BloomScreenLevelDay=75BloomCurveDay=0BloomPowerNight=18BloomConstantNight=0BloomCurveNight=0BloomScreenLevelNight=20BloomAdaptationScreenLevel=24BloomAdaptationMultiplier=100BloomAllowOversaturation=1BloomMaxLimit=100[sSAO]UseFilter=1OcclusionQuality=2FilterQuality=1DarkeningLevel=30BrighteningLevel=30IlluminationLevel=30AdditiveIlluminationLevel=30UseAmbientOcclusion=1UseIndirectLighting=1FadeDistance=50UseForAlphaTest=0UseForAlphaBlend=0[colorCORRECTION]DarkeningAmountDay=21ScreenLevelDay=70ScreenLevelNight=1DarkeningAmountNight=10GammaCurveDay=0GammaCurveNight=-2ColorSaturationDay=-1.75ColorSaturationNight=-2.00UsePaletteTexture=0[WATER]UseWaterDeep=0WaterDeepness=20WaterQuality=0[sHADOW]ShadowFadeStart=40ShadowFadeEnd=80ShadowAmountDay=100ShadowAmountNight=30ShadowScreenLevelDay=60ShadowScreenLevelNight=20ShadowQuality=1UseShadowFilter=0FilterQuality=2ShadowBlurRange=30[ENGINE]ForceAnisotropicFiltering=1MaxAnisotropy=16ForceDisplayRefreshRate=0DisplayRefreshRateHz=60[MOTIONBLUR]MotionBlurQuality=1MotionBlurVelocity=0MotionBlurRotation=0[PERPIXELLIGHTING]SpecularColorMin=0SpecularColorMax=100SpecularColorMultiplier=100SpecularGlossinessMin=0SpecularGlossinessMax=100SpecularGlossinessMultiplier=100[DEPTHOFFIELD]DOFQuality=2DOFNumberOfPasses=1DOFFocusRange=50DOFBlurinessRange=10[PROXY]EnableProxyLibrary=0InitProxyFunctions=1Regards!

0

Share this post


Link to post
Share on other sites

Thanks!It seems better with yout setup. I do not have fps losses (or marginal) but I still have from time to time those weird black lines...Paolo

0

Share this post


Link to post
Share on other sites

Any news on the black stripes/spikes? I have the same problem, and I am trying to find a solution. I will post back if I find one. Happy for any thoughts on this!

0

Share this post


Link to post
Share on other sites
Any news on the black stripes/spikes? I have the same problem, and I am trying to find a solution. I will post back if I find one. Happy for any thoughts on this!
I have discovered that (at least on my rig) the black lines go away when you press [ALT] to display the top menu of FSX. I can live with that...Paolo
0

Share this post


Link to post
Share on other sites
I have discovered that (at least on my rig) the black lines go away when you press [ALT] to display the top menu of FSX. I can live with that...Paolo
Same here! :)
0

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0