Jump to content
Sign in to follow this  
davjones

CH yoke / standby mode problem

Recommended Posts

This is not entirely an FS problem, but manifests itself with FS hardware, so I hope it'll be okay to post it here. Besides, I'm pretty sure some people here know the answer to it.I just replaced the motherboard in my PC, and kept all of my old stuff. The "old stuff" means the power supply, CPU, memory, hard disks, etc., and I got lucky -- since the new MB uses the same Nvidia chipset as before, Win XP came up happy and did not require a reinstall -- it came up pretty much as though nothing had been touched. I did just recall that the video card was changed out at the same time. Used to be an Nvidia 7300 and is now a 9800GT with 2 monitors. At one time that same 9800 was working in the old PC though -- and standby mode worked normally.The ONE problem I do have now is that when I put the PC in standby mode, if I touch the CH yoke or rudder pedals, when the system comes back up, windows detects "new" hardware and insists that I install the drivers for it. The remedy is to reboot the PC and everything goes back to normal.My sense is that this has to do with a power management setting in the BIOS (Phoenix Award V6, I believe). Does this ring any bells with anyone here? One more clue: when the PC is in standby, the fan continues to run, instead of being put fully to "sleep" as it used to. Failing that, can someone post their Phoenix BIOS power mgmt. settings for me?Maybe I'm heading up the wrong trail, but the BIOS is one of the few things that HAS changed.Thanks for any help!...DaveDave JonesFort McCoy, Florida USA

Share this post


Link to post
Share on other sites

DaveAs I recall there are a couple of posts over on the CH forums at CH_Hangar (http://www.ch-hangar.com/forum/forum.php) about this issue. The guru over there Bob Church will be able to help. Unfortunately using stand by mode does create the behviour you describe and as the OS wakes up it thinks that there are new game controllers installed and usually resets all the buttons, keys and axes to the default. My advice if you don't have to use stand by mode then don't. :( I think that it also depends of you are using CH Manager and whether or not you have that in "Direct" or "MAP" mode. Connect to the USB ports directly connected to the mobo where possible and also make sure that you click "Don't let Windows kill the hubs for power saving" in your settings, and if you have the "Selective Suspend" it should be OFF".I would post on the CH Hangar forum and get Bob's expert opinion.RegardsPeterH

Share this post


Link to post
Share on other sites
DaveAs I recall there are a couple of posts over on the CH forums at CH_Hangar (http://www.ch-hangar.com/forum/forum.php) about this issue. The guru over there Bob Church will be able to help. Unfortunately using stand by mode does create the behviour you describe and as the OS wakes up it thinks that there are new game controllers installed and usually resets all the buttons, keys and axes to the default. My advice if you don't have to use stand by mode then don't. :( I think that it also depends of you are using CH Manager and whether or not you have that in "Direct" or "MAP" mode. Connect to the USB ports directly connected to the mobo where possible and also make sure that you click "Don't let Windows kill the hubs for power saving" in your settings, and if you have the "Selective Suspend" it should be OFF".I would post on the CH Hangar forum and get Bob's expert opinion.RegardsPeterH
Hi Peter,Just want to say thanks for your advice, and I did take the problem to CH. Bob Church gave a detailed reply as you suggested he might. The problem may end up not having a solution.One thing I noticed is that when the PC come back from standby, there's a USB symbol on my bar. Naturally curious about it, I clicked the thing and it brought up a message saying that there was a problem because a "High-Speed USB device is connected to a non-High-Speed USB port". It is followed by a lengthy list of mostly non-existent ports to which I should connect the device. Yet all of my USB ports are 2.0, which so far as I know is high-speed (I think!) AH, Windows... :( Still gets me though because everything is the same, with the possible exceptions of the USB drivers and maybe some BIOS settings. Can't find much about the "selective suspend" or how to control it. I DID check the box that prohibits Windows from killing the port to save power, as you suggested. Finally, can you tell me where in the CH Manager I fo to change the direct/mapped mode? I don't see that one.Thanks again for your help!...Dave

Share this post


Link to post
Share on other sites

Hi DaveI'm in my Logitech G940 mode so this is from memory.You open the CHCM and along the top there are several options and one of these is "Direct" mode. You need to be in that in order to calibrate the joystick. There's also a little app - check with Bob - its called CMStart, and using that will ensure that the CHCM is in direct mode everytime you start Windows. I've seen a fix somewhere on that USB 2.0/1.0 try googling USB 2 and 1 error or similar.Keep us up to dateRegardsPeterH

Share this post


Link to post
Share on other sites
Hi DaveI'm in my Logitech G940 mode so this is from memory.You open the CHCM and along the top there are several options and one of these is "Direct" mode. You need to be in that in order to calibrate the joystick. There's also a little app - check with Bob - its called CMStart, and using that will ensure that the CHCM is in direct mode everytime you start Windows. I've seen a fix somewhere on that USB 2.0/1.0 try googling USB 2 and 1 error or similar.Keep us up to dateRegardsPeterH
Peter-Your memory must be good - that's exactly how you get to direct mode in CHCM. Will see what I can find out about that USB 1.0/2.0 error.Thanks for all your help. It's guys like you that really makes this a great resource....Dave

Share this post


Link to post
Share on other sites

Peter (and anyone else whom this may help later):I've been taking some time to dig further into the problem, continuing to feel that some setting had been upset.What I finally came to is in the BIOS, under Power Management Setup, there's an option to set ACPI suspend type. Changing it from S1 to S3 eliminated the problem. I almost knew I had it when the fan turned off on going into standby, as it used to with my old PC, but continued running since all this started.The various suspend types specify how much stuff gets turned off during standby mode.I love happy endings......Dave

Share this post


Link to post
Share on other sites
Peter (and anyone else whom this may help later):I've been taking some time to dig further into the problem, continuing to feel that some setting had been upset.What I finally came to is in the BIOS, under Power Management Setup, there's an option to set ACPI suspend type. Changing it from S1 to S3 eliminated the problem. I almost knew I had it when the fan turned off on going into standby, as it used to with my old PC, but continued running since all this started.The various suspend types specify how much stuff gets turned off during standby mode.I love happy endings... So do I :( ...Dave
DaveIt might be worth posting this on the CH-Hangar Forum via Bob Church as it could be useful to CH users.RegardsPeter

Share this post


Link to post
Share on other sites
DaveIt might be worth posting this on the CH-Hangar Forum via Bob Church as it could be useful to CH users.RegardsPeter
Hi Peter,Yes, I agree with you, and actually I posted it there before I posted it here. I'm sure others will trip over this problem in the future. That's what's so good about these forums -- everybody can help everybody else and we all end up better off......Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...