Jump to content

Archived

This topic is now archived and is closed to further replies.

BadKarmaPT

Problem installing ATI Catalyst Driver Package

Recommended Posts

Hello,I've been having this problem for quite some time now and though I've searched for a solution I haven't found one yet. :Cry: I have an aging Sapphire ATI Radeon HD 3870 X2 card and I'm running the 9.9 Catalyst drivers on Windows XP SP3.I decided (a while ago) to update my drivers, so I downloaded the latest Catalyst driver package from amd.com and tried to update.The package extracts to C:\Ati but the installer never starts. I get heavy HD activity for a while and nothing else.I've read it could be a problem with Microsoft Visual C++ so I uninstalled and reinstalled all the versions I had on my system (2005, 2005 SP1, 2008, 2008 SP1 and 2010) but it didn't help.I've tried different driver packages but the problem remains. :mad: Any ideas on how to solve this problem?Thank you in advance.

Share this post


Link to post
Share on other sites

×
×
  • Create New...