Sign in to follow this  
Guest DanielBu

Looking for better performance

Recommended Posts

MSFS2004: COF performs badly on my system not only that it looks terrible too.When I look out the window I can see ground textures slowly loading and they don

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello,I'm sorry to hear that the game's not performing up to snuff for you. I have done quite a bit of fiddling around and tweaking in the past following tips and tricks listed in this forum and using my own computer knowledge/experience to get FS2004 running good. Then after I was finished with fiddling/tweaking around I saw someone(Terblanche) asking for a fairly comprehensive all in one guide, and although I think that is pretty neigh impossible, I took my best shot. I would like to suggest that you read the following thread...http://forums.avsim.net/dcboard.php?az=sho...topic_id=154952In that thread you will find a link to my guide and I would like to suggest that you read it. ;) Just in case and for thoroughness I will give you a link to the guide right here...http://forums.avsim.net/dcboard.php?az=sho...topic_id=149511I do not claim to be any kind of know-it-all guru expert so I was just happy to see that my guide was pretty well received. :D It's really more on tweaking your BIOS settings and WinXP than FS2004. But it has my own FS9.cfg settings in it and refers you to the sticky threads at the top of this forum for the tweaks/settings contained therein.Good Luck,Jim

Share this post


Link to post
Share on other sites

Ok I have worked out that I need to disable AGP texture Acceleration but not in direct X.I have also found that I have to change direct sound acceleration to to basic.I have turned air traffic down to 10 and definetly dont have aa turned on.Are there any other major performance boosts I should know about?

Share this post


Link to post
Share on other sites

This is what I've done:fs9.cfgINTERNATIONALTEXTURE_BLDG=0GRAPHICSTERRAIN_USE_VECTOR_OBJECTS=0DISPLAY.Device.RADEON 9700 PRO .0PanelAsTexture=0TERRAINTERRAIN_USE_GRADIENT_MAP=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=4.50000TERRAIN_EXTENDED_LEVELS=4display.cfg:----------------------------------------------------------------------; ATI Radeon DDR Win2k/XP;----------------------------------------------------------------------[00001002:00005144:ati2dvag.dll]RenderToTexture=0[00001002:00005144:ati2dvag.dll.1]MinDriverRev=6.14.0010.6343RenderToTexture=2Is there any way to stop the annoying screen flickering that goes on before and after flights? It is so annoying.

Share this post


Link to post
Share on other sites

This is what I've done:fs9.cfg[iNTERNATIONAL]TEXTURE_BLDG=0[GRAPHICS]TERRAIN_USE_VECTOR_OBJECTS=0[DISPLAY.Device.RADEON 9700 PRO .0]PanelAsTexture=0[TERRAIN]TERRAIN_USE_GRADIENT_MAP=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=4.50000TERRAIN_EXTENDED_LEVELS=4display.cfg:----------------------------------------------------------------------; ATI Radeon DDR Win2k/XP;----------------------------------------------------------------------[00001002:00005144:ati2dvag.dll]RenderToTexture=0[00001002:00005144:ati2dvag.dll.1]MinDriverRev=6.14.0010.6343RenderToTexture=2Is there any way to stop the annoying screen flickering that goes on before and after flights? It is so annoying.

Share this post


Link to post
Share on other sites

Yes, although I have not done it myself. Go to either www.omegacorner.com or www.driverheaven.net and get the latest ATI Omega drivers. Then, uninstall the ATI Control Panel and do not reboot. Then install the Omega drivers and reboot. According to everyone else on here that's done that, that should take care of it. I hope things are working out better for you now that you've done some adjusting/tweaking.Take Care,JimEDIT:With as much RAM as you have I wouldn't think you'd need the PanelAsTexture=0 tweak. It might even hurt your performance when in the 2D panel. If you notice such, you can of course always undo it.Jim

Share this post


Link to post
Share on other sites

I suspect there's more going on here than just a problem with sim set-up. The first clue is here:"Ok I have worked out that I need to disable AGP texture Acceleration but not in direct X."You should not be disabling AGP Texture Acceleration. Doing so is holding back all that your video card can offer you. You should check your chipset drivers. Nvidia keeps promising new drivers, but they have yet to appear for several months. Evenso, your system is not giving you all that it has to offer.As Jim said, the latest Omega drivers are the ones you want. They are the 2.4.96b (shown at Driverheaven as 2496b). The only change I had to make to the sim after installing the 2.4.96's was to set "PanelAsTexture=1".With regard to sim tweaking, the first thing I recommend is getting rid of the Display.cfg. Yes... you read that right. Get rid of it. Move it out of your FS9 folder to someplace else. Mine has been off my system for 2 months, and the sim runs fine without it. You can set-up your FS9.cfg to work without it AND control the specific driver you wish the sim to use. Here is that section of my FS9.cfg (square brackets removed because the forum precludes their use):DISPLAY.Device.RADEON 9700 PRO (Omega 2.4.96b)Mode=1280x960x32AntiAlias=0TriLinear=1TextureAGP=1 PanelAsTexture=1DISPLAY.Device.RADEON 9700 PRO (Omega 2.4.96b) .0Mode=1280x960x32TriLinear=1TextureAGP=1 DISPLAYUPPER_FRAMERATE_LIMIT=24TEXTURE_BANDWIDTH_MULT=200DisableSoftwareWarning=1I would delete the FS9.cfg (after backing it up) and allow the sim to build a new one. You'll have to reconfigure your settings in the sim, but deleting the .cfg often proves beneficial in cleaning out unwanted garbage from the file.Good luck with your trouble shooting. Look to your system first. My system is very close to yours, and the sim runs well for me.system:AMD 3000XP 400 @ 2300MhzASUS A7N8X Deluxe Rev 2.0 1005 BIOS1 Gb Corsair XMS PC 3200 6,3,3,2ATI 9700 Pro 350/330 Omega 2.4.96bMaxtor 40 Gb 7200 ATA 133Sony 52x24x52 CD-RWIomega 100 Mb ZipTurtle Beach soundLian-Li Case with Antec Truepower 430W PSUWindows XP SP1

Share this post


Link to post
Share on other sites

Is it possible that you are running some programs in the background? E.g. Antivirus. OR is it possible that you actually have a virus?Your problem sounds like there's a lot of harddrive access (slow loading of textures, ...), so maybe some other programs are stealing performance.-Daniel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this