Sign in to follow this  
Guest DanielBu

Shimmering (swimming textures)

Recommended Posts

First of all, I have been monitoring this forum for say 4 years now and used many tips in this forum, thanks for that.I'll introduce myself first:23 winters oldATPL holder (theory)PPL (A)200Hrs total timeNow to get back to the subject, I'm using fs9 for some time now but I have a few problems or actually 1 major problem, my textures are crisp and clear but they are shimmering all over the place, I tried just about everything, tried every AA an AF setting there is with no succes, changed the settings in fs itself but just can't solve this problem. If anyone can help please I'm running out of options hereMikeP4P 800 Deluxe (newest drivers and bios)P4 2.4c@ 3Ghz512 mb PC2700 (PC4000 very soon)Geforce FX 5900 Ultra (52.16) (tried the 53.03)Maxtor 80GB@7200rpm

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi there,could you post your settings, especially your resolution and mip map settings? Generally I'd recommend a mip mapping detail setting of 4 (or maybe even 3 and a higher AF setting) and AF of 4 or 8, there shouldn't be much shimmering going on with these settings. Antialiasing should help too.-Daniel

Share this post


Link to post
Share on other sites

Thanks for the reply Daniel,I'm running 1280*1024*32 (max for my monitor) and 4*s AA and 8*AF, setting a higher level of AA actually decrease quality, I'm happy with my fps and overal quality but I would really like to get rid of this shimmering of the ground textures, they start when I leave the 2d cockpit for the 3d environment, the trees and buildings are bad but the bridges is the worst especially the suspension. Ifiddled some with the mip map slider but that didn't help so now its back on 4. I changed the fs9.cfg, I set the TEXTURE_BANDWIDTH_MULT=400,TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=4.500000I can't really see the difference with these settings except for the TEXTURE_BANDWIDTH_MULT=400 after that the textures loaded much faster. I tried different drivers without succes, Any help would me much appriciated, Posting a screenshot is useless, don't now how to make a small video to show what I mean, thanks in advance,MikeP4P800 Deluxe (newest bios and drivers)P42.4C@3Ghz512MB PC2700 (soon PC4000)80GB Maxtor@7200rpmGeforce FX 5900 ULTRA 52.16

Share this post


Link to post
Share on other sites

Hmm...what if you reduce the mip detail level to 3? The textures will become slightly ugly, but if you are referring to the same shimmering that I am referring to, it might help with your configuration.-Daniel

Share this post


Link to post
Share on other sites

thanks again Daniel,I'm afraid not, setting the mip map any lower just results in a ugly picture, the ''dancing'' of the objects still remains, setting it any higher then 4, the problem is even more pronounced.Thanks,Mike

Share this post


Link to post
Share on other sites

And what if you turn AF off? But maybe it's the z-buffer (the shimmering is different though)...it should 32bits.-Daniel

Share this post


Link to post
Share on other sites

Hello.I've decided to hit hard on this topic.I find the problem aggravating, and I was hoping it would get more attention.Maybe just a few unlucky ones are experiencing it. I've downloaded Rage3DTweak, which allows to tweak many parameter in DirectX, but I haven't had any success so far. As much as I can, I will try to bump this topic to the top of the forum to see if we can find anyone with a possible solution.Just to make sure we all agree, I'm not talking about diffused shimmering of distant scenery and autogen, which can be reduced to an acceptable level by lowering the mip-mapping slider, but rather about the AWFUL and EXTREMELY NOTICEABLE trembling of distant mountain horizon and clouds intersecting with mountain ridges. I hope I've been clear enough. Thanks for your attention.luca

Share this post


Link to post
Share on other sites

Hello.I've decided to hit hard on this topic.I find the problem aggravating, and I was hoping it would get more attention.Maybe just a few unlucky ones are experiencing it. I've downloaded Rage3DTweak, which allows to tweak many parameter in DirectX, but I haven't had any success so far. As much as I can, I will try to bump this topic to the top of the forum to see if we can find anyone with a possible solution.Just to make sure we all agree, I'm not talking about diffused shimmering of distant scenery and autogen, which can be reduced to an acceptable level by lowering the mip-mapping slider, but rather about the AWFUL and EXTREMELY NOTICEABLE trembling of distant mountain horizon and clouds intersecting with mountain ridges. I hope I've been clear enough. Thanks for your attention.lucaThanks for that post Luca,Like I said in another post on this subject it really surprises me that there is so little attention for this, it is hard to believe we are the only ones having this problem, it is even harder to believe people are experiencing the same problem but are not annoyed by this.I will too keep fiddling with the settings untlill I can come up with a solution, any other form of flying than solid IMC is very annoying, let's hope someone comes with a answer for this,Mike

Share this post


Link to post
Share on other sites

Hi Mike, I've posted this topic by mistake in the other SHIMMERING AND DANCING topic, so now I'm pasting it the right place. Hope I haven't created too much confusion."...it is even harder to believe people are experiencing the same problem but are not annoyed by this."You've said it all! The thing is SO bad!Today I'm home from work, and here I go wasting a few more hours hopelessly trying to resolve this FLYING KILLER. At least it's good to know someone out there knows what I'm talking about. And I'm afraid my eyes will not be able to get over this "bug".As exagerated as I may sound, It's either the shimmering going away, or the sim going off my hard drive.luca

Share this post


Link to post
Share on other sites

Thanks Luca,It's a good thing to pinpoint this discussion, it doesn't help if everyone is talking about something else, I made a similar post on the simflight forum, just to increase the change of finding a solution, I will not leave this issue unsolved, I'll keep on trying,Mike

Share this post


Link to post
Share on other sites

Hi all,I've had the same problem and it was driving me nuts! After trying various drivers and tweaking various settings without success, I set all the Scenery settings to Low to see if the shimmering stopped, with the intention of working up from there if it did. I'm on a 3.2GHz P4 with 9800 Radeon Pro 256Mb and Catalyst 3.9 drivers.The shimmering did stop at the lowest settings so I gradually increased them to see where the problem started. Surprisingly, I was able to get right up to maximum on the Scenery settings without the shimmering. On the Hardware settings, all the boxes were ticked, mip mapping at 4, hardware-rendered lights at 6, 6 x AA and 1024x768x32. It was OK on 1280x768x32.Having done that, it was mostly OK on subsequent fs9 sessions. The shimmering has occurred a few time since but not often. When it does I just set the Scenery settings to Low again, enter the flight and set all the settings straight back to where I want them. A couple of times this hasn't worked but restarting fs9 as well as doing the above has then fixed it.I don't have a clue why this works and I haven't spent any more time to work out whether it is one particular setting that is a problem. It would be good to have a complete cure but in the absence of that this fix works for me and I can live with that.Hope this helps somebody.

Share this post


Link to post
Share on other sites

I have an athlon 2600XP based system with 1 gig 333mhz DDR Ram, and Radeon 9700(np). I use the Cat 3.4 drivers. The shimmering used to drive me nuts too....especially bad when flying over cities when all the windows in the buildings swam and danced all OVER the place!!I have the scenery barely shimmering now, and the city problem brought to a less distracting level by setting AA to 4x, and Aniso at 8x, in the Radeon display control panel. In game, I found that selecting tri-linear filtering pretty much cured the city/windows problem. I also have the Texture_multi at 200 in the FS9.cfg. Mipmapping is at 4. The only problem now is of the inevitable frame-rate hits when around densly populated airports, etc...oh well!!!

Share this post


Link to post
Share on other sites

I experienced the shimmering. My fix was two things. First I reduced my mip map settings (I think it is at 4 or 5 right now) and then I disabled my throttle control on my joystick. I think it was "dirty" and causing most of the problem. Hope this helps!

Share this post


Link to post
Share on other sites

Just to make things sure, I hope we all agree that AUTOGEN AND DISTANT SCENERY SHIMMERING doesn't have aything to do with TREMBLING OF DISTANT MOUNTAIN HORIZON AND CLOUDS INTERSECTING MOUNTAINS. To my opinion, the two problems are of different nature and should probably be treated that way. Mip-mapping settings, as well as anisotropic filtering or AA, don't have ANY effect whatsoever on the TREMBLING issue.luca

Share this post


Link to post
Share on other sites

I've contacted Creative labs support for my Geforce FX5900 Ultra, since so few of us are experiencing this problem it's not unthinkable that the hardware is faulty, I simply don't have any other options to try. If there is something interesting in their reply I'll post it here.Mike

Share this post


Link to post
Share on other sites

Hi Mike.Thanks for keeping up the subject.I own an ATI Radeon9800 Pro. I find it somewhat strange that we both have the same problem on two different cards, and have to assume it's a hardware fault. I'm afraid it's rather a combination of how fs9 renders graphics, probably coupled with a driver problem. For example, I still can't move the aircraft around in the preview window using the mouse, just because my cursor disappears. On the other hand, this problem doesn't occur if I play in windowed mode; this is definitely a driver issue. Maybe I should write ATI about it, but I'm extremely skeptical on single-customer feedback from major hardware companies. It's worth to try any possible solution anyway.Good luck, and let us know.luca

Share this post


Link to post
Share on other sites

I know it's pretty strange that both ATI and Nvidia cards seem to have the same problem. But since we are the only ones having this kind of problem chances are it's not a driver problem. I simply don't have any options left, faulty hardware is the only thing I can think of now, I'll keep you informed,Mike

Share this post


Link to post
Share on other sites

You know what? In the end you may be right!But damn, are we the only two people who are experiencing this?At this point I think I'm next to having tried every possible solution, software-wise.People who have posted so far in this topic don't seem to have grasped the difference between shimmering and trembling as we experience it. I feel somehow privileged it's happening only to us two!I'm obviously just kidding; I'm next to going crazy for this crappy thing. It's just NOT possible to fly with everything in front of your cockpit shaking like a rattle snake.And no, I'm not going to resolve this by going flying where there are no mountains!The thing is, when you fly with clear weather and you have mountains in the distant horizon, trembling is just absolutely unbearable. Then you load real weather, find out that clouds covering the trembling mountains somehow make things a little better only to discover, after taking off, that EVERY SINGLE DAMN CLOUD intersecting mountains and hills shakes just as bad!Sorry Mike, I'm so frustrated about this. I've spent just about two months tweaking the sim right, and then this crap comes out, after I've spent my monthly income to buy a video-card.Unfortunally the problem is evident on a fresh installation of the sim, too.Let me know about your findings. I'll keep this up as long as I have the energy.luca

Share this post


Link to post
Share on other sites

I too have had this problam. Even though i havent solved it completely im happy with the results for now. I have a fx5200 on a AMD 1.3MHZ system. Here are a few tips.Use a program to override the default refresh rate of FS. It will run at 60 Hz no matter what refresh rate you have your monitor set at. I used RefreshForce and it did help a lot. There is a another utility called Rivatuner though i havent figured out how to use it. Use high resolutions such as 1600*1200 combined with AA/AF controlled by card. AA will cure much of the shimmering but will hit performance especially with clouds and Nvidia cards. I have AA disabled because my system can not handle it. If you have a fast system use AA.When i run FS04 in 1920*1440 and AA/AF 4x/8x my shimmering is almost completely gone, but so are also FPS. By turning AA off i get very little shimmering and the hit on my computer is much less. I hope MS addresses this problem soon and come up with a solution, doesnt seem like the card manufacturers do.

Share this post


Link to post
Share on other sites

ej74, thanks for your post.I must reply by saying:1) I'm already overriding the 60Hz base frequency. I'm running at 1024x768@85Hz2) My monitor doesn't handle 1600x1200, and running at my highest resolution possible leaves the problem unsolved3) AA and AF don't have any effect whatsoever on the SHAKING. Yes, the SHAKING, NOT the SHIMMERING. I'm afraid we are getting things confused, here. I'm experiencing SHAKING OF DISTANT MOUNTAIN HORIZON WHENEVER I TURN MY VIEWPOINT AROUND (in ALL available simulator views) AND SEVERE FLICKERING OF CLOUDS IN THE POINT WHERE THEY INTERSECT MOUNTAINS. Bare with me, please!Thanks for your attention!luca

Share this post


Link to post
Share on other sites

Hit the start menu/programs/microsoft games/fs2004/troubleshooting/reset defaults. See if that solves your problems. I remember some of the beta testers mention that things went all to heck and that did the trick. Like the game gets out of sync every now and then and that corrects it.

Share this post


Link to post
Share on other sites

Lurk...you are indeed priviliged to have this problem! I can guess at what you mean, but I don't get that trembling effect when flying over cloud covered mountains. I enjoy flying from Heathrow to Rome (Fumi) IFR across the Alps, and use real weather, but where the clouds and mountains meet, there is just a line...slightly unreal, but no trembling. You are using a Radeon 9800, if I remember correctly? Which Cats are you using? I stayed with the 3.4's because after those, other problems showed up in other games.....the settings I described earlier give me a good stable image with little of that shimmering, and certainly no trembling!Oh!! As an after-thought...try setting Vsynch to 'On'....that stops tearing, and could possibly be causing your problem (texture tearing)?

Share this post


Link to post
Share on other sites

Ok. The problem is that I would have to post a video showing the unstable mountain horizon effect, as well as clouds vibrating in the point where they meet mountains. But I really don't have the time to get so involved. I just wish I could fly without having major annoyances, such as this damn shaking effect is!I thank you for your understanding anyway, and maybe I'll try out an older version of the Cats and see what happens.And yes, I do own a 9800Pro, and believe me, it hasn't yet given me a reason to think it was money well spent. But this is a totally different discussion to get involved in...luca

Share this post


Link to post
Share on other sites

Sorry if I insist. I've attached two images. The red rectangles show where the shaking is taking place in this particular case. Shaking of clouds gets worse as you fly above any area with mountains. Mountain horizon shakes just the same regardless of flight level and arcraft position, and is evident as soon as your aricraft moves or view point changes.I'm obviously desperate, as you can probably tell by the frequency of my postings.P.S. Older driver versions are not making any difference.Damn. I'm quite ###### at this point.luca

Share this post


Link to post
Share on other sites

Have you even considered that your joystick may be causing the problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this