Jump to content

Archived

This topic is now archived and is closed to further replies.

CPTDANNO

Shallow S-turns on roll-out

Recommended Posts

During the landing roll-out the aircraft makes shallow S-turns all the way down to the full stop. Additionally, the aircraft does not follow the runway centerline. I have considered just turning off the autopilot early on (after touchdown) and attempt to provide directional control manually, but I'm relatively certain that this would not be acceptable in the real world during an autoland. I'm going to try doing a flight control re-calibration just prior to the approach phase and see if there is an issue there. I use a Saitek X52 Flight Control System.

Share this post


Link to post
Share on other sites

I believe that after the aircraft has all wheels on the ground, spoilers and reverse are deployed, the autopilot is suppose to come off as it has done its job for the autoland.

Share this post


Link to post
Share on other sites

CptDanno.You need to sign your posts with your full name, forum rules. :( I'm assuming you are doing an autoland here. What were the wind conditions like during this landing?The aircraft should track the centerline pretty accurately during the landing roll. Normally I disengage everything as I decelerate through 60 knots.

Share this post


Link to post
Share on other sites

Sorry about that (I had enable signature checked and just didn't notice) and yes this was an autoland. This was also a no wind landing. I have since done a "Ctrl+K" to disable my Saitek X52 Flight Control System while on approach and landed on RW30L at KMSP with a perfect landing and roll-out right down the centerline with no weaving whatsoever. My brakes also worked without problems. I'll try other airports with or without my flight controls enabled and report back. I will also do another axis calibration just prior to landing. Daniel Braden CPT DANNO

Share this post


Link to post
Share on other sites
Sorry about that (I had enable signature checked and just didn't notice) and yes this was an autoland. This was also a no wind landing. I have since done a "Ctrl+K" to disable my Saitek X52 Flight Control System while on approach and landed on RW30L at KMSP with a perfect landing and roll-out right down the centerline with no weaving whatsoever. My brakes also worked without problems. I'll try other airports with or without my flight controls enabled and report back. I will also do another axis calibration just prior to landing. Daniel Braden CPT DANNO
Hi Daniel,It sounds like your X52 is a suspect, so certainly a recalibration would be a good start. The other thing you might want to check is in the PMDG options menu. From memory I can't recall the exact name of the option but it relates to your controls overriding the autopilot commands. Set the option so that your controls DO NOT override the autopilot commands and this should also address the issue without forcing you to disable your X52.

Share this post


Link to post
Share on other sites

×
×
  • Create New...