Archived

This topic is now archived and is closed to further replies.

Superpilotv2

Ruder axis not working

Recommended Posts

Hi guys, my old Saitek Cyborg Evo stick, which I´m using now arround 4 years with absolutely zero problems, seems to reach his limit. Yesterday the armrest broke away and the stick seems to be more sluggish now (Don´t know whether this is related to the broken armrest.). About one year ago I bought me the Saitek Cyborg X as an replacement for this stick but I had some problems with it: After more than 1 month the ruder axis didn´t respond anymore whereas all other axis and buttons worked. So I send that back and got an replacement. Wich worked for about the same time and then from one moment to the other the same happened again. But I forgot to send it back the second time, so he rested under my bed till now. After the breaking of my old one I thought to give this stick a go and try to fix that problem. Stick was successfully installed by windows and recalibrated but the ruder axis refuses to work. Has someone a solution for that? i don´t have the money to buy me a new one so I would be very happy if this one would work.Btw. I also had an Saitek X52 Flight system one time but I also had to return it cause after the Saitek drivers installation also the ruder axis refused to work and I never got it working again. Since then I chagend my system to windows 7 and also the hardware ia another than back then.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!