Archived

This topic is now archived and is closed to further replies.

martinlest2

FS9 has stopped working: stops at 'Generating scenery file indexes'

Recommended Posts

Hi, I really hope somebody can help me troubleshoot this.

 

Over the past two days, when I start up FS9, the splash screen just sits there - "Completing Setup: Generating scenery file indexes' (or at the first splash screen if no changes have been made since last startup). It won't progress beyond that. In Process Monitor, I see that FS9.exe is not listed in the Process Name column (usually there are thousands of entries showing as FS9 starts up) - though FS9.exe *32 does show in Task manager in Processes. In the Application tab, it shows as 'Not responding'. The little blue 'thinking about it' circle (Win7) just sits there, rotating, when I hover the mouse over the FS9 window.

 

I installed a couple of new aircraft - some new gauges and effects, but I have removed all these and still no FS9. I installed the files and folders manually, so I am pretty sure I know what changes were made. I have restored the scenery.cfg file and fs9.cfg files from a backup made a few days ago (when all was fine). Gaugesound.dll is as it was before, same date and version.

 

Then, to make things more mysterious, sometimes FS9 WILL start OK, my having done nothing in the interim. I shut down FS9 and try again. Now nothing. Driving me nuts...

 

Finally (for now!), I keep an 'out-of-the-box' installation of FS9.1 on the same drive, for testing purposes (no addons, just as installed from the DCs and updates to 9.1). When I rename my problem FS9 folder with an XXX and then use the 'clean version', it runs just fine (shocking how quickly FS9 loads too!!), so there must be an issue with a file somewhere in the main FS2004 folder. I did try replacing the whole Microsoft/FS9 folder in 'Roaming') with a backup from just a few days back, but no change.

 

Does anyone know what factors stop FS9 loading at the stage it does? Not being able to use FS9 is a fate almost worse than death!!! My next step is to copy over folders gradually from the full, now faulty FS9 to the 'out-of-the-box' installation and see at which point there is a problem, but that may not be conclusive even then (sometimes OK, next time not): I will start with AFCAD files, as that seems the most likely problem: any leads meanwhile would be much appreciated.

 

Thanks,

 

Martin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

OK, sorted. I was put off by the fact that I had installed new aircraft and gauges - it was a scenery file (for CYTZ) that I had recently installed. I had put the file in my CYYZ folder (as it was just one bgl file) and it worked there fine for a few days - then the problems as above started. No idea why it didn't happen immediately. I moved the file to a folder lower down in priority and now FS9 runs fine again. What a relief.

 

M

Share this post


Link to post
Share on other sites