Archived

This topic is now archived and is closed to further replies.

Kyle94

NGX banks hard to right or left before touchdown

Recommended Posts

When I am about 30 feet above the runway (with autopilot off) and flaring to land the rudder makes a hard left or right causing the plane to bank in that direction.

 

It happens randomly and I have no idea what the problem might be I have installed the latest update and also tried reinstalling the aircraft but the problem persist. 

 

Does anybody know why this happens and what may be able fix it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Kyle

 

What weather program are you using? 

I had a similar problem and this was caused by wake turbulence created by AS2012. I went into the settings and removed the wake turbulence. After that I never had it again.

 

It came during flare and most of the times a plane was waiting for takeoff when I was landing, but it happened also with no aircraft at all on the airport.

 

Jesper

Share this post


Link to post
Share on other sites

Hi Kyle

 

What weather program are you using? 

I had a similar problem and this was caused by wake turbulence created by AS2012. I went into the settings and removed the wake turbulence. After that I never had it again.

 

It came during flare and most of the times a plane was waiting for takeoff when I was landing, but it happened also with no aircraft at all on the airport.

 

Jesper

Hi Jesper,

 

I use AS2012 and I also noticed it happened mostly when there were other aircraft holding short or just landed on the runway.

 

I will give your solution a try but do I have to remove wake turbulence from the FSX settings or AS2012 settings?

 

Thanks for your help.

 

Kyle

Share this post


Link to post
Share on other sites

Last time I had a similar problem I found I had a number of Controller settings duplicated - so e.g. a rudder input controlled ailerons too - so I'd check your FSX controls to see if you've any stick/button controls duplicated.

Share this post


Link to post
Share on other sites