Sign in to follow this  
MarkSC

Saitek MultiPanel Display Not Working with Windows 8.1

Recommended Posts

I posted this in the joystick thread, but thought I would highlight it here for others that may have the same problem. The Saitek multipanel LED display no longer works for me in Windows 8.1. The buttons and flap switch and knobs work fine, but the display is dark. Even a reset of the USB or the computer does not fix it. Nor does using a USB 2.0 input. After searching other forums, this problem has been reported for Xplane and P3D too, so it is not an FSX issue. It is also not driver dependent, as users have experienced it with both SPAD and Saitek drivers. I emailed Saitek tech support about it. They say that windows 8.1 is causing them a lot of problems and that the side effects "were not expected" but it does not sound too likely that a fix is coming soon. They basically are blaming MS. If anyone has this problem and has found a solution, please post.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This might be what you are looking for.

 

http://support.microsoft.com/kb/2900614

 

Bill

 

Yes, that worked! Of course, there are no updated Saitek drivers, so I tried the manual solution. I had no idea which of the many devices was the right one, so I just disabled enhanced power management for all of them.  Many thanks!

Share this post


Link to post
Share on other sites

Hello, I know I am replying to a very old topic, but I would like to enhance this far better than the Microsoft link to the complex author's way of USB power management. This has alway been an issues since the early Windows iterations and it has never been properly resolved bewteen MS and Intel. And I have tested this on on all Windows operating systems desktops, including laptops, up to 10 Home and Pro native and with the 1511 service pack installed. Much easier this way.

 

In a nut shell, one opens the device manager, type "device manager" without the quotes, into the W10 "Search"

Then click on Device Manager that show up in the list. Once the Device manager opens it's window, go to the bottom of the list and open the "Universal Serial Bus controllers, by clicking on the little arrow on the left. Then finally right click each and all of the devices listed "....Hubs" select "Properties", in the opening window go to the last tab indicating "Power Management" and untick the option that says "Allow the computer to turn off this device to save power". Do this for all of the hubs listed on your system, even those that you plug in, plug them in if not at this time. If you are not sure simply right click all USB devices and click "Properties" on all of them. You will see those that have the "Power management" tab to do this. Uncheck all of them that you find and you will have full power all of the time to any plugged in USB device. I do this as standard practice on all computers, due to the poor ongoing MS and Intel crap with power management to USB. You might notice, like my Thrustmaster F16 MFD panels do, that the displays and /or LED's will flash through boot up until you have logged in.
 

But it certainly does resolve the majority of power delivery to high capacity devices attached to USB ports. And especially the dim to non-functioning displays on Saitek and other brand panels.

 

Good luck going forward.

 

Andrew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this