Sign in to follow this  
Lurk

clouds and mountains, bad combo

Recommended Posts

hi, flying on the alps with real weather (REX) and I get horrible flickering where clouds meet terrain. I understand this is a limitation of FSX engine and the way Z-buffer is handled with polygons, but is there anyway to mitigate this? It's a really disturbing effect and indeed a shame, because graphically speaking I'd be in FSX nirvana otherwise! Flying DX10 with fixer, REX clouds are 1024 DXT5 optimized.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Lurk,

 

This is a known FSX issue, so please follow my instructions below:

 

1. Close FSX

2. Open REX

3. Navigate to the CONFIGURATION MANAGER / CLOUDS tab

4. UN-CHECK 'Enable Realistic Haze Layer'

 

Hope this helps!

Share this post


Link to post
Share on other sites

thanx timest, I already have haze disabled.

after a bit of searching around, I recon this has to do with Z-fighting and it's an issue with the way polygons are handled in the distance.

This article describes exactly what I'm seeing when cloud sprites meet mountainous terrain, and I'm afraid it can't be cured that easily.

 

http://en.wikipedia.org/wiki/Z-fighting

 

It is very evident in wing view on the default A321, more less so in cockpit and spot plane views. I can live with FSX forever as it is, I'm really enjoying the way I've setup graphics after a lot of tweaking. The no.1 improvement to this otherwise optimal situation would be for a developer to introduce volumetric clouds and fog! :Praying:

 

p.s. I found that using REX 4096 clouds somehow mitigates the problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this