Sign in to follow this  
BIGAL79

Dx10 full screen issues

Recommended Posts

Ok folks. Here is an issues that has got my last nerve on dx10. I have an AMD 8150 8 core processor

Gtx670 4gb

16gb Ram

Needless to say I can run anything. In FSX dx9 runs like a champ. Full screen and windowed. I always play in full screen on 3 monitors. I have a home built simulator so 2 monitors on the so called dash and the large monitor for flying.

I recently started learning about DX10. So I watched a few videos on how to set up Nvidia inspector for DX10. Completed the fsx.cfg tweaks for DX10. Turn fsx on and in windowed mode it's down right amazing. Thanks to flightfx and Rex essentials + overdrive my graphics are life like.

Now here lies the problem. Dx10 in full screen is unplayable. What could be the problem? I've spent hours and hours trying to get this to work. Someone please help. And a few other notes. The dx10 fixer I did purchase and install. Got the 3.2.2 patch. I know it's a simple setting change I just can figure it out. Thanks in advanced for any input on this.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Based on the fact you stated in your last paragraph that you purchased and installed the DX10 Fixer and then got the 3.2.2 patch, it's not installed properly.  But, that's okay as that is what these forums are all about and set you in the right direction.  If DX10 works great for you in DX9, it should work just the same in DX10 Preview.  There is no special button to click whatsoever.  All you needed to do was install the DX10 Fixer that you purchased.  No other installations was required.  I might add too that you should look at the new AVSIM FSX Configuration Guide for proper FSX/NI settings.  You have a good system that should run DX10 well.  Good luck!

 

Best regards,

Jim

Share this post


Link to post

Funny you say it's not installed right. I tired reinstalling the whole thing and I get an error can't find script folder when I hit setup.dat. This aught to be interesting

Share this post


Link to post

I found a working option but by far not the fix. I found that if I remove the dxgi and the dxgi.dll from the FSX Root folder. Full Screen now works for DX10. When i did the new root folder I installed just the fix that i had purchased and with that alone (fullscreen) didnt not work still. Still looking for other alternatives. Thanks for your replies.

Share this post


Link to post

I found a working option but by far not the fix. I found that if I remove the dxgi and the dxgi.dll from the FSX Root folder. Full Screen now works for DX10. When i did the new root folder I installed just the fix that i had purchased and with that alone (fullscreen) didnt not work still. Still looking for other alternatives. Thanks for your replies.

Sounds like you have SweetFX installed as those files do not belong in the main fsx folder and only belong to SweetFX.  You should make sure the following files are removed from your main FSX folder - D3d9.dll, D3d9.fx, Dxgi.dll, Shader.fx, and the injector.ini.

 

Best regards,

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this