Sign in to follow this  
rallye

FreeTrack not working with Prepar3D V2 (works in FSX)

Recommended Posts

Hello Everyone,

I trying to use FreeTrack V2.2 lastest version with Prepar3d V2, without success so far.

I have "log" P3D simconnect, which shows no connection :
_________________________________________________________
0.00000 SimConnect version 2.0.0.0

0.04641 Server: Scope=local, Protocol=IPv4, Address=127.0.0.1, Port=60500, MaxClients=256
0.07365 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Lockheed Martin Prepar3D v2\SimConnect, MaxClients=64
0.09884 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Microsoft Flight Simulator\SimConnect, MaxClients=64
0.12397 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Microsoft ESP\SimConnect, MaxClients=64
0.15788 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Lockheed Martin® Prepar3D™\SimConnect, MaxClients=64
0.19010 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Lockheed Martin Prepar3D v2\SimConnect, MaxClients=64
0.22349 Server: Scope=local, Protocol=IPv6, Address=::1, Port=10596, MaxClients=64
0.25513 Server: Scope=local, Protocol=IPv4, Address=127.0.0.1, Port=10597, MaxClients=64
_________________________________________________________

Here is a simconnect log of working FSX with FreeTrack
_________________________________________________________

0.00000 SimConnect version 10.0.61259.0

0.02441 Server: Scope=local, Protocol=IPv4, Address=127.0.0.1, Port=60500, MaxClients=256
0.05035 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Microsoft Flight Simulator\SimConnect, MaxClients=64
0.06509 Server: Scope=local, Protocol=IPv6, Address=::1, Port=11431, MaxClients=64
0.07523 Server: Scope=local, Protocol=IPv4, Address=127.0.0.1, Port=11432, MaxClients=64

 
0.15271 Exe Launched:  Path="C:\Program Files (x86)\AICarriers\aicarriers.exe"  CommandLine="-nogui"  Version="<Unknown>"
_________________________________________________________
> 33.09625 [383, 1]Open: Version=0x00000002  Name="Set Data"
> 33.09635 [383, 2]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09639 [383, 3]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09642 [383, 4]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09644 [383, 5]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09646 [383, 6]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09649 [383, 7]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09651 [383, 8]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09654 [383, 9]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
> 33.09656 [383, 10]CameraSetRelative6DOF:fDeltaX=0.027193, fDeltaY=-0.005697, fDeltaZ=-0.728215, fPitchDeg=63.536755, fBankDeg=0.050098, fHeadingDeg=-65.701195
_________________________________________________________

For that I have used a simconnect.ini
_________________________________________________________
[simConnect]
level=Verbose
console=Yes
file=C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\SimConnect%01u.Log
file_max_index=9
_________________________________________________________

I have the same simconnect.xml in both FSX and P3D
_________________________________________________________
?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
 <Descr>SimConnect</Descr>
 <Filename>SimConnect.xml</Filename>
 <Disabled>False</Disabled>
 <SimConnect.Comm>
   <Disabled>False</Disabled>
   <Protocol>IPv4</Protocol>
   <Scope>local</Scope>
   <Address>127.0.0.1</Address>
   <MaxClients>256</MaxClients>
   <Port>60500</Port>
   <MaxRecvSize>4096</MaxRecvSize>
   <DisableNagle>False</DisableNagle>
 </SimConnect.Comm>
</SimBase.Document>
_________________________________________________________

I use this simconnect.cfg for FreeTrack :
_________________________________________________________
[simConnect.0]
Protocol=IPv4
Address=127.0.0.1
Port=60500
MaxReceiveSize=4096
DisableNagle=0
_________________________________________________________

Any idea or comment are welcome.

Thank you for your time,

Looking forward to read you,

Rallye
 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

It has worked for me since Day 1. Sorry that Im not much help with your problem, but I can't think of anything I did other than load p3d V2 and fire up FreeTrack.

Have you installed the P3D SDK? Not sure that's a solution, either.

Do you have all the proper simconnect files in their correct folders. and that the IP addresses are correct?

 

John

Share this post


Link to post
Hello John,
Thank you for taking the time to reply, I did not except anymore after 2 weeks. Very glad anyway.
I have read that you first start P3D then FreeTrack, it did not work for me. I have to start FreeTrack
first then FSX or P3D or FreeTrack freeze. The same happen with OpenTrack, which works sometimes
better than FreeTrack (filters and source codes available).
If you can spend more, could you please provide me your simconnect.cfg & .xml and screenshots of freetrack or the .ini file to compare with mines.
I do not have the SDK installed, but I do not think this could be the solution. I do not have it either in FSX.
If you have more time, please have a look at my own files, they work with fSX but not with P3D (same for opentrack), but as I wrote before I have to start freetrack (or opentrack) first.
 
Any idea or comment are welcome.

Thank you for your time,

Looking forward to read you,

Rallye

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this