Sign in to follow this  
DarrianCZE

Certain elements are not working

Recommended Posts

Hello guys! 

First of all I would like to say that you are doing incredible job with DP.

 

Now... I have a little problem. My friend and I are trying to fly with PMDG with DP. Some basic elements are working. Like battery switch... or MCP. Let's say, that my friend as an FO will arm the Emergency Exit Lights. We are using the table for DP 1.4.3 which describes what can FO and what can CPT use. But when he will arm Emergency Exit lights... or let's say Fastern Seat Belt Switch... nothing happens.

 

So simply... few elements are not working, and due to documentation... they should.

 

When I will take a look into his and mine server log... there is indeed an communication pending between us... for example when using ground power.

 

Have anyone experienced this issue? 

 

Thanks!

Edited by DarrianCZE

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I did notice that while the emergency lights are in the arm position without the cap closed causes some issues with the simulator.

 

Try arming the lights by closing the cap, that should solve your problem.

Share this post


Link to post
Share on other sites

I did notice that while the emergency lights are in the arm position without the cap closed causes some issues with the simulator.

 

Try arming the lights by closing the cap, that should solve your problem.

I am afraid that we were arming them just this way. And also other things in overhead panel were not working. For example Window Heat, or Fastern Seat Belt switch.

Share this post


Link to post
Share on other sites

Run the DP Compatibility Tester.exe on both simulators and report back.

Share this post


Link to post
Share on other sites

Already done that. Sucess. And ports are forwarded on both computers. So basicly everything is as it should be. 

Share this post


Link to post
Share on other sites

Have both of you installed PMDG's SP1c and added EnableDataBroadcast = 1 to both 737NGX_Option.ini files?

Share this post


Link to post
Share on other sites

Yes we have :-) As I said... everything according to manual. That's why it's bothering me. Besides, we both own FS2Crew, so we need both these things in order to get FS2Crew working. (Don't worry, we are not dumb enough to use FS2Crew when in shared cockpit :D )

 

This is the reason why I am writing here. In normal situations I am able to solve these problems myself. But this is a mystery.

Share this post


Link to post
Share on other sites

Okie dokie.

 

When you forwarded the ports did you forward them through your modem/router? Have you also checked if your firewalls are blocking it?

 

While Desk Pilot and FSX is running open resource monitor and click the 'Network' tab. Look for the NGX Desk Pilot(SERVER) v1.4.3 Free.exe under 'Processes with Network Activity' and tick the check box next to it.

Now scroll down to 'Listening Ports' and check the 'Firewall Status' it should say "Allowed, not restricted". Otherwise add a incoming firewall exception for the dp server and client on both pc's or disable the firewalls.

Share this post


Link to post
Share on other sites

It was forwarded via Router, and both of us have Firewall and Antivirus disabled for the flying.

Share this post


Link to post
Share on other sites

Just to make sure port 60000 has been forwarded correctly to your pc. Download the PFPortCheck Program from http://portforward.com/help/portcheck.htm

 

Put 60000 into "Port Number To Check" and change the protocol to "UDP" and press the "Check Me" button. Let me know if it reports a open or closed status.

Share this post


Link to post
Share on other sites

Hello. I am back again. I was finally able to test it again. So... little update. I have tried everything you have written here. I have tried PortCheck as well... and it's working.

 

But when I try to do something in the cockpit... my friend is not seeing any activity. In my role of captain... I tried Battery Switch or Left Course on MCP. I can see his activity... But he can't see mine.

Share this post


Link to post
Share on other sites

What happens if you switch positions and you become the first officer instead?

 

If you guys are connecting to each other successfully, receiving the in game messages on both pc's and only one person is seeing the actions. It comes down to PMDG's service pack..

 

Are you and your friend absolutely sure SP1c is installed and EnableDataBroadcast=1 has been added to the 737NGX_Options.ini file on both pc's?

[SDK]
EnableDataBroadcast=1

It must be exactly the same as the lines above. Including [sDK]

 

Can you both browse to your "PMDG 737 NGX\" installation directory, open the "README_PMDG_737-800-900_NGX.txt" file and check the version. It should be version v1.00.3219.

Share this post


Link to post
Share on other sites

If I will switch to the First Officer, everything works fine. I will try it with some other friend.

 

But we are 100% sure that we have SP1c, and we have also following line in 737NGX_Options.ini

Share this post


Link to post
Share on other sites

Hmmm..

 

If everything works fine when your'e running the client. It must be a networking issue related to a firewall or router.

 

Most firewalls will block incoming and allow outgoing by default. When you disabled the firewall was it a third party firewall like Symantec? or the default windows firewall?

Share this post


Link to post
Share on other sites

I know that I have tried to disable firewall and antivirus. I have tried also to disable it inside router. 

Share this post


Link to post
Share on other sites

Actually... we have been using Hamachi from the very beginning. I'll try to look into the firewall problem more

Share this post


Link to post
Share on other sites

Are you and your friend using hamachi's virtual ip address to connect? I believe you would have to use it instead of your global address.

If you are connecting via hamachi's address, can you try a direct connection with your global ip address and not hamachi?

Share this post


Link to post
Share on other sites

I know how hamachi works :D We have been using Hamachi adress. And I will try it now with another friend and I will give you a report.

Share this post


Link to post
Share on other sites

Okay... so I'm here with the results. Same thing occured than previously. I have double checked everything including Hamachi and network settings. Everything is set and fine... but still... I can see what FO is doing... but FO can't se my actions. I really don't know what to do more. I am absolutely helpless with this.

 

So... maybe... would it be possible to try it with you? If you have time. I think that it's simply the last thing which comes to my mind. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this