Jump to content

Sign in to follow this  
ronzie

joystick disconnects / dropout

Recommended Posts

Guest mstram

I'm running MSFS 2002 / Win 98 / DirecX 8.14, using a Wingman Extreme controller/pad.At random intervals MSFS "loses" the joystick. When it happens, the options menu "enable/disable" joystick is greyed out. When I run the wingman utility, it says "no joystick found". The only solution is to reboot.This is probably a Win98/DirectX / Wingman driver problem ?? or maybe a hardware problem.Just wondering if anybody has experienced something similar and what the solution was.thxMike

Share this post


Link to post
Share on other sites

Check in Device Manager and Control Panel power management sections that USB devices are not allowed to be disabled if processor resources or power availability is scarce. Make sure USB is not allowed to be suspended.FYI I have better USB stability under W98SE than W98. Also make sure your drivers are of the latest update and also check your BIOS settings for USB port management power if any.I usually open up before FS the gaming options icon from control panel, click on each USB device to open it and exercise it to insure it is working. These devices do not always come up unless they are exercised in this manner for all axes. It is a startup timing issue with W98 and should be checked before starting FS.

Share this post


Link to post
Share on other sites
Guest mstram

Thanks for the suggestions !There is no "USB" option under power management.However I *did* run the "gaming options" before startting FS and it seems to be working.thx againMike>Check in Device Manager and Control Panel power management>sections that USB devices are not allowed to be disabled if>processor resources or power availability is scarce. Make sure>USB is not allowed to be suspended.>>FYI I have better USB stability under W98SE than W98. Also>make sure your drivers are of the latest update and also check>your BIOS settings for USB port management power if any.>>I usually open up before FS the gaming options icon from>control panel, click on each USB device to open it and>exercise it to insure it is working. These devices do not>always come up unless they are exercised in this manner for>all axes. It is a startup timing issue with W98 and should be>checked before starting FS.>

Share this post


Link to post
Share on other sites

Go to device manager and look at the advanced section of properties of usb root hubs and controllers. I found an allow usb errors selection and a bandwidth selection on my ASUS mobo P4P800-E Deluxe, an Intel 865PE/ICH5R chipset.I have seen posts here, check the hardware forum, on the USB shutdown to conserve resources/power but can't recall the location of this setting.Also, this may seem unnecessary to comment on, but check the cables and connections to insure they are solid.Some older mobos had a problem delivering consistent USB power. I use a powered external hub for FS control connections to provide a "buffer". That was a mobo made a long time ago and it was a known issue.If you have multiple USB devices disconnecting then I'd look at these alternative issues.Does the device disconnect on any port or a specific port. This could be a good clue to what's going on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...