Sign in to follow this  
Curly

False rate of climb indication

Recommended Posts

I checked my rate of climb with: with a 1600 fpm indication I only get a 1000 fpm real climb.

The simulation rate is normal the pitot heat is on and the altimeter setting is correct.

 

There is a very strange feeling of something holding back the plane. Acceleration on take off

is also very slow. My Flight One Mustang is very hot and realistic compared to this one.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The phenom 100 is made really bad ... ... ... Let's just hope, that there will be an update that resolves issues!

Share this post


Link to post
Share on other sites

I've only done one flight in the Phenom so far but didn't notice the VS indicator being out. Having a quick read of some other sources:

 

The Phenom in reality doesn't climb all that well.

 

What are your detent settings and what speed are you climbing at?

 

Anywhere around 1200 to 1500 ft/min is about right.

 

Climb at 200 KIAS at Con/clmb detent and see how you go.

 

30,000 ft in 25 mins should be achievable.

 

Here are some real world comparisons:

 

http://www.google.com.au/url?sa=t&rct=j&q=embraer%20phenom%20100%20vs%20mustang&source=web&cd=5&ved=0CEYQFjAE&url=http%3A%2F%2Fwww.corporatejetsolutions.com%2FPDF%2FAircraft%2520Comparisons%2FMustang%2520v.%2520Phenom%2520300.pdf&ei=CfJNU8bDPMXXkAXw8IHwDw&usg=AFQjCNEM___pTu3RD3pGWh6eJ9IbGdzKyg&bvm=bv.64764171,d.dGI

 

Sorry couldn't quite get the url to copy on my phone, but it's a pdf comparison between the Cessna Mustang and Embraer Phenom 100.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this