Sign in to follow this  
Rob Ainscough

ASN Network Config and P3DV2.2 not working for me

Recommended Posts

Hey all,

 

I'm running P3DV2.2 (Professional Plus) with Hot-Fix v 2.2.10438.0.

 

I have installed FSX-SP2 SimConnect client v10.0.61259.0 on both client and server.

 

All networked drivers have been successfully mapped.

 

Firewalls are turned OFF.

 

virus software is turned OFF.

 

When I start ASN v1.0.5210.22113 I get Sim Connection: Waiting for Simulator ... this never changes (P3DV2.2 is running) and no weather is injected. The log file seems to indicate it's finding and connecting to P3D_SimConnect, however the UI reports no such connection and no weather is injected.

 

On a side note: I have installing ASN on the server (aka P3DV2.2 computer) and it does work and function correctly "from the server".

 

Any suggestions for getting the network configuration working?

 

Cheers, Rob.

 

EDIT: I have submitted a support ticket with ASN folks, but thought I'd try here to see if anyone else might have some insight.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just the basics but, do you have the Simconnect.xml and .cfg files in the correct locations ?

 

IIRC, there should be identical Simconnect.cfg files in the main Documents folder for the active account, on both the server and client, and then Simconnect.xml in the P3D2 appdata folder.

 

As examples, my Simconnect.cfg:

 

[SimConnect]
Protocol=IPv4
Address=10.0.0.2
Port=4506
MaxReceiveSize=4096
DisableNagle=No

and my Simconnect.xml:

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>10.0.0.2</Address>
    <MaxClients>64</MaxClients>
    <Port>4506</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>local</Scope>
    <Address>127.0.0.1</Address>
    <MaxClients>64</MaxClients>
    <Port>4507</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>

EDIT: Just to note that the IPs shown in the .cfgs and in the global section of the .xml are for the P3D/FSX machine. Might be obvious, but just wanted to clarify in any case.

Share this post


Link to post
Share on other sites

Hi Rob,

 

I'll respond here so maybe this will be helpful to others too. ASN for P3D doesn't use FSX version of SimConnect.

 

It comes with the managed dll of LM version of SimConnect. In contrast to FSX version of SC, this needs .NET 4.0 and correctly installed VC++ 2010 runtime (on both the client and the server). .NET 4.x in contrast to .NET 2.0 is not an integral part of Win7 (assuming the client is using Win7 here). So making sure these 2 are correctly installed is significant. Other than that, all the config steps are similar to what's done in FSX

 

This is advice coming from similar problems we had from support tickets. In addition, I am not sure if installing the fsx version of SimConnect to the GAC, may "confuse" the runtime in some cases. Not sure about this.

 

 

EDIT: We decided to use the new version of SC, so that any problems will come up early (meaning now) and we'll have a chance of attempting to solve them. Moving forward, this will also give us a chance to take advantage of any new/different functionality LM is willing to provide through the new SC versions. In the end however, if we find that this is more of a trouble for most users, we may revert back to using the "standard" old fsx SC version (that LM has kept working just for compatibility reasons with older addons).

Share this post


Link to post
Share on other sites

I had the same problem after installing P3D v2.2. It was user error though as I forgot the simmconnect files wouldn't be where they belonged after the install. Be sure you have the SimConnect.xml file in your Appdata/roaming/lockheed martin/Prepar3d folder and it's configured properly.

Share this post


Link to post
Share on other sites

this needs .NET 4.0 and correctly installed VC++ 2010 runtime (on both the client and the server). .NET 4.x in contrast to .NET 2.0 is not an integral part of Win7 (assuming the client is using Win7 here).

 

I have .NET 4.5.1 installed (which includes .NET 4.0) and VC++ 2010 (10.0.30319).

 

I installed the FSX-SP2 simconnect after I couldn't get ASN to work in network configuration ... didn't help the problem, so I'll go ahead and remove FSX-SP2 simconnect.

 

 

 

there should be identical Simconnect.cfg files in the main Documents folder for the active account, on both the server and client, and then Simconnect.xml in the P3D2 appdata folder.

 

Are you sure the Simconnect.cfg is supposed to be in the "documents" folder -- where flights are saved?  I would think it should be in AppData\Roaming along with other .cfg files?

 

I forgot the simmconnect files wouldn't be where they belonged after the install.

 

Ah ... ok, these files don't exist anywhere.  Just curious, what process normally creates these files?  or has it always been a manual process like DLL.XML and EXE.XML and/or 3rd party setup?

 

 

Documents folder for the active account, on both the server and client,

 

Are you sure they need to be in both server and client ... the client has mapped full user access to these server shares so I assume it should be able to read those.

Share this post


Link to post
Share on other sites

It's manual as far as I know Rob. However, if you already have the SimConnect.xml file in your FSX appdata directory, you can simply copy it over to the Prepar3D appdata directory.


Here's my SimConnect.xml file for reference (the Address can be the PC name or IP address):

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
<Descr>SimConnect Server Configuration</Descr>
<Filename>SimConnect.xml</Filename>
<Disabled>False</Disabled>
<!-- Example Global (remote) IPv4 Server Configuration-->
<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>global</Scope>
<MaxClients>64</MaxClients>
<Address>i7</Address>
<Port>500</Port>
</SimConnect.Comm>
<!-- Example Local IPv4 Server Configuration-->
<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>local</Scope>
<MaxClients>64</MaxClients>
<Address>127.0.0.1</Address>
<Port>REPLACE_WITH_PORT_NUMBER</Port>
</SimConnect.Comm>
</SimBase.Document>

Share this post


Link to post
Share on other sites

Yep, I'm sure .cfg files just sit loose in the main Documents folder on both the server and client, and the xml goes into appdata.

Share this post


Link to post
Share on other sites

Thanks all, your responses were very helpful -- it's working like a charm ... except during dusk/dawn of course ;)

 

Not sure why the SimConnect.cfg needs to be duplicated on server and client, but it is what it is.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this