Jump to content
Sign in to follow this  

PFC Yoke not recognized by windows after calibrating with PFC utility

Recommended Posts

Initially calibrated in Windows no problem.

In Prepar 3D 2.2 ,a few airplanes felt a little slow in roll and elevator response so I decided to calibrate it using the PFC calibration utility from the CD, After I did the calibration following the steps, now Windows still recognized the Yoke , but when I go to windows calibration, it wont recognized it, under the calibration window I move the axes and nothing happens.


When I start Prepar 3D or X plane the yoke axis are not recognized either.


If I start the PFC Test utility axes are moving fine and smooth.

If I recalbrate using the utility from PFC axes are recognized there too.


Any ideas what went wrong?

Or how to fix it?

I uninstalled it and desconnect it and still not recognized.


Share this post

Link to post
Share on other sites

Solved, selected joystick in the program instead of USB Yoke, although it is a USB yoke.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...