Sign in to follow this  
Guest badbiggles

Help- Brakes stuck on in FS9

Recommended Posts

Just started using FS9 and have a brake problem - the Brake(s)won't release. I have CHProducts USB Yoke and pedals. I tried deletingthe "x" and "y" axis of the rudder pedals.....but no luck. Is this a glitch rendering the pedal brakes useless, or could there be a workaround somewhere? Any advice would be much appreciated...Thanks, Bill.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This is a shot in the dark but try it :)On your keyboard press CTRL and then . (period key)If that doesnt work try keeping the left mouse button pressed and drag the mouse to the left/right.Hope u find a solution soon!

Share this post


Link to post
Share on other sites

>I tried deleting the "x" and "y" axis of the rudder pedals.....but no luck.This should have eliminated the problem. Have you examined the Joystick section of you FS9.cfg file to insure that they are really gone?If you want to fix the problem, then make sure that your brake axes are reversed. There is a checkbox to tick in the axis assignment area of FS9 "Options" menu. R-

Share this post


Link to post
Share on other sites

Hi Bill,I had this problem with the CH pedals. I installed the CH Control Manager (latest version is 3.6 I think) and calibrated the pedals and I also defined a deadzone for the toe brakes. No problems with sticky brakes after that.Ulf B

Share this post


Link to post
Share on other sites

Thanks for the input...here's an update: I did check "reverse" on the "x" and "y" axis in flightsim, and when I started up again the BRAKES were off...However, as soon as I (barely) touch a rudder pedal, they are stuck on again!??. I have calibrated in CHManager 3.6, but have not done any changes there, because quite honestly, it is notuser-friendly. And, just to complicate matters, keystroke brakes has no affect...thanks again, Bill

Share this post


Link to post
Share on other sites

Check that none of your other controllers have a brake command entry. FS2004 allows multiple controllers to have assignments for the same command which can lead to conflicts.

Share this post


Link to post
Share on other sites

SwanflyTry thisFS9/ Controls/Sensitivities - Go to Pro PedalsthenSimple - Sensitivities - all axes - make sure slider is well to the right or hard rightBadbiggles:-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this