Sign in to follow this  
jfail

OPUS/OPUSFSI conflict with simconnect

Recommended Posts

I was having nothing but trouble with my Saitek Instrument Panels (the FIP's, not the panels that work fine with SPAD) working in P3D V2.2 10438.  I finally figured out that the problem was simconnect being the wrong version.  A user over at the P3D forum suggested I might be using the wrong version of simconnect and the Saitek FIP drivers needed an older version.  I found in Prepar3D V2 > redist > Interface > FSX-RTM > retail > lib > simconnect.msi.  That installed version 10.0.60905.0 of simconnect.  My FIP;s started working fine at that point.

 

Now a new problem has arisen,  when I run OPUS or OPFSI I get an error.  I have a screenshot but I don't know how to attach a screenshot to my post.

 

The error is:

 

System. TypeInitializationException:  The type initializer for 'd" threw an exception.

---> System.IO.FileNotFoundException.  The specified module could not be found.

(Exception from HRESULT: 0x800700E)

at.d..cctor()

--- End of inner exception stack trace ---

at a3a.a(String[],a_0)

 

 

I tried re-booting but it did not help.  If I remove the simconnect by using control panel then OPUS/OPUSFSI work fine again.

 

So what do I do now??  I hate to give up my FIP's after all my hard work to run that problem down but I also don't want to give up OPUS/OPUSFSI.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You should use the new or current version of SimConnect as the old one will not work with anything other than outdated software, the old one will not even be fully compatible with the simulator unless you intend installing an old version of FSX, of the same era. So you will have to install the current and only useful SimConnect library using our supplied SimConnect.msi Microsoft installation file.

 

As for the compatibility of the Saitek panels, best ask Saitek about that one. You can't use the old SimConnect version though its not compatible with any up to date software, simulator or Addon.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Thanks Stephen, using your simconnect.msi works fine all the way around.

 

John

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this