Sign in to follow this  
AKStirling

Installation error

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Hi Alan,

 

This is covered by our FAQ, normally implies you don't have SimConnect installed (use our supplied SimConnect.msi).

 

FAQ ...

 

System.TypeInitialisationException error

 

You need Microsoft.NET version 2 and SimConnect to be installed for OpusFSX and its SimConnect links to work.

 

You can check what versions of .NET you have installed by checking your c:\Windows\Microsoft.NET\Framework or Framework64 folders. You should see a v2.0.xxxxx folder in addition to the v4.0.xxxxx folder.

 

In the case of SimConnect, first make sure you have installed FSX or P3D along with its SP2 or installed the FSX Acceleration version, SimConnect is usually installed automatically with it. There is a know problem with P3D v2.1, you may need to install SimConnect. If you have mislaid or corrupted your SimConnect or are using OpusFSX on a client PC only for Client Side Weather Control (where FSX is not installed) then you can install it using the SimConnect.msi file within your OpusFSX folder.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this