Sign in to follow this  
Marlon115

OpusFSX and my Yoke

Recommended Posts

Dear,

 

I have a question;

 

Everytime i start FSX everythings works fine, no problems.

The moment i startup OpusFSX to work with FSX it throw away my Yoke and Pedals(Saitek) and my joystick(Logitech 3D ForceFeedback).

 

Can you tell me what the problem is and how to solve it.

 

Thanks

 

Marlon.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Apart from a game controller that is configured into the LCC we don't interface to any other joystick etc so best check your LCC configuration. That is the only place where we read the device.

Are you sure you are not running the client as well as the server on the same flying PC and hence freezing the sim?

Share this post


Link to post
Share on other sites

Maybe it sound stupid but what do you mean with LCC and where can i find this.

 

No i'm not running the client as well as the server on the same flying PC. My sim is not freezing, because with the mouse and keyboard i can still work with FSX.

Only the Yoke, pedals and joystick are throw away. If i restart FSX i can see them again.

 

And this happens on every aircraft i tried with OpusFSX.

Share this post


Link to post
Share on other sites

As I said OpusFSX does not interface to the sticks, it gets all buttons through SimConnect. But it will use DirectX to read the axes of a dedicated LCC controller. You would have needed to specify the controller to Opus via the Shortcuts - LCC dialog. But even this would not cause the sim to loose its controllers. Do you have any SimConnect exceptions reported via our spy window?

 

FSX will only read its controllers in on start up so if it looses then it may not recover. But the Opus software will not interact with them at all. Perhaps it's a memory problem or something causing your drivers to drop out or something.

 

Stephen

 

Try running the FSXSERVER manually after the sim has loaded its flight and settled down. When Opus connects via SimConnect it does inform the sim what sticks and button events it wants to receive. I wonder if this is causing a problem during start up on your system.

 

Stephen

Share this post


Link to post
Share on other sites

The problem is solved.

 

When i install OpusFSX i forgot to share the directory. Now everything is working again.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this