Sign in to follow this  
dukeav

How to stop the 5 sec beep?

Recommended Posts

I believe this beep comes when there is Opus is not able to connect to TrackIR. How to disable it?

 

The point is that I can "see" that TrackIR is not working, I don't need this constant beep sound to tell me. In some cases I have just closed TrackIR as I don't want to use it temporarily.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You DO need the constant beep because the beep is warning you something is wrong. It's telling you nothing has connected to the TrackIR interface, so either you have wrongly enabled the TrackIR option in the Opus Config dialog, or you intend to use the TrackIR interface but have not set it up correctly (most likely you have not renamed the TrackIR manifest files or ensured OpusFSX is present in your TrackIR game list).

 

So the beeps ARE very necessary, and very useful.

 

Stephen :-)

 

If you don't want to run TrackIR then simply turn off the TrackIR option in the Opus Config. Not only will the software operate more efficiently but the beeping will stop as the Opus TrackIR interface will no longer be active. Of course you can also simply run TrackIR and pause it when not needed. Either case only takes a second to do.

 

Stephen :-)

Share this post


Link to post
Share on other sites

You DO need the constant beep because the beep is warning you something is wrong. It's telling you nothing has connected to the TrackIR interface, so either you have wrongly enabled the TrackIR option in the Opus Config dialog, or you intend to use the TrackIR interface but have not set it up correctly (most likely you have not renamed the TrackIR manifest files or ensured OpusFSX is present in your TrackIR game list).

 

So the beeps ARE very necessary, and very useful.

 

Stephen :-)

 

If you don't want to run TrackIR then simply turn off the TrackIR option in the Opus Config. Not only will the software operate more efficiently but the beeping will stop as the Opus TrackIR interface will no longer be active. Of course you can also simply run TrackIR and pause it when not needed. Either case only takes a second to do.

 

Stephen :-)

 

In the failure case, I already know when TrackIR is not working, I can "see" it => I move my head and camera does not move.

 

I close TrackIR when I do not need it for some flights, I don't want to get into the options every time I need to enable/disable it. This is not a setup issue which the beep needs to remind me to fix.

 

IMHO, the beep has no purpose. The symptoms of failure are evident visually and also in the Opus command-line window. 

Share this post


Link to post
Share on other sites

You wouldn't see it if TrackIR connected directly to the sim because it's manifest files either hadn't been renamed or the TrackIR software had been updated and new manifest files had been created. I can attest to this by the number of people who have and continue to fall into this trap.

 

I will look to disable any subsequent beep warning once a successful connection by TrackIR has been achieved, hence you can shutdown TrackIR after it connects rather than simply disabling or pausing it.

 

Stephen

Share this post


Link to post
Share on other sites

 

 


You wouldn't see it if TrackIR connected directly to the sim because it's manifest files either hadn't been renamed or the TrackIR software had been updated and new manifest files had been created. I can attest to this by the number of people who have and continue to fall into this trap.

 

Right. Maybe you can have a GUI indication like "Operating Mode" in green, which show TrackIR status. 

 

Thanks for looking in this.

 

Needless to say, excellent service :)

Share this post


Link to post
Share on other sites

TrackIR provides its own indications. I have just checked the software and the interface will only beep until TrackIR connects to it, after that the beep is silent even if you shut down the TrackIR program. So its already doing what I proposed to implement, just let it connect before shutting it down.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this