Sign in to follow this  
Phillip Gallagher

No buttons work

Recommended Posts

I'm new to using LINDA.  Just registered FSUIPC.  But after several hours,  I cannot get LINDA to perform any of my key presses.  In LINDA, under the appropriate joystick it says that the command is indicated.  For example, I set up no smoking signs and seat belt signs and mapped them to my Saitek X52.  I deleted these assignments in FSX.  But when I press any of the buttons nothing happens.  I haven't got a single button to work yet with LINDA.  Anybody have any ideas?    

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Phillip

 

Welcome to LINDA and sorry to hear that you are having problems. I assume you are using Linda 2.5 with your X52 only. Is the joystick shown as connected on the summary page? When you press a button does it highlight a numbered line on the joystick page?

 

If not try the following. Open FSUIPC4 and confirm that the button shows up on the buttons page. Make sure you have saved the joystick page when assign a new function to a button.

 

If that fails PM a copy of your config-hid.lua file from \fsx\modules\linda-cfg\{your aircraft}\ folder.

 

Let me know how you get on.

Share this post


Link to post
Share on other sites

Hi ScotFlieger,

 

I am running the X52, CH Yoke, and the Saitek multi, radio, and switch panels.  They all show up in LINDA as "ok." When I press a button the numbered line DOES show and the corresponding command I choose fills in.  In LINDA I DO get a message that "FSUIPC files not found"  Tonight, when I get home I will post that file. Thank you for your assistance!  -Phil

Share this post


Link to post
Share on other sites

Hi Phil, that is intriguing because all you said suggests it should work except that you say you get he message that "FSUIPC files not found".  In addition to the config-hid.lua file can you send me a copy of the initial start up log on the LINDA Console. 

Edited by ScotFlieger
corrected file name

Share this post


Link to post
Share on other sites

I tried to reproduce those things here but was unable to.  In the main Linda screen I get:

 

Configuration checklist

 

Joysticks/HID devices

 

ch yoke

Saitek x52

pro flight radio panel

multi panel

switch panel

                                                   Everything is ok!

VRinsight MCP combo

 

device enabled

COM port not set

                                                   Setup required

 

FSX/FSUIPC configs

 

  FSUIPC files not found!

                                                   Setup required

 

I have a registered copy of FSUIPC and all my joysticks and panels show at bottom.  Not using VRinsight     

 

Thanks for your time.  If I can't get it to work I'll survive but it looks like a great program. : ) 

Share this post


Link to post
Share on other sites

Hi Philip

 

Thank you for the information and your patience. I note that you do not have any VRInsight MCP panels but the 'FSUIPC files not found - Setup Required' means that you do need to select the Setup MCP Combo page and run the FSUIPC config setup. You will need both LINDA and FSX to be running to do this.  You should also un-tick the MCP Enabled checkbox.

Share this post


Link to post
Share on other sites

Hi Phil

 

As I said please PM me you config-hid.lua file and a copy of the Console report on start up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this