Jump to content

Sign in to follow this  
Foxtrot_Sim

Rudder magically stopped working.

Recommended Posts

Yes, that's correct.

 

My Saitek rudder pedals have been working perfectly for the past 4 years that I have had them, and one day after closing the sim, they decided not to work next time started again.

 

It's weird because I reinstalled Windows 8 and my Saitek joystick and throttle set are not being recognized in device manger. When the sim starts, they light up and work, but when the sim is closed, they are dark and are not recognized by my computer. I have tried to disable "Computer cuts power to device to save power." option in the device manager, but they are not listed. I tried installing drivers from Saitek.com, but they driver installer doesn't recognize them either.

 

Anyone know what is going on with my USB ports? Outside of this, any item I plug into a USB port is not recognized by the computer.

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...