Sign in to follow this  
Max Reverse

HDG Toggle

Recommended Posts

Hello,

I hope thats not the wrong forum. I am using the latest LINDA and Günters LUA Script 1.2.

In this LUA script is written, for toggeling the HDG between managed and normal use No. 22.

 

But this seems not to work. I can assign No. 20 HDG mode normal or No. 21 HDG mode managed

but not HDG mode No. 22.

 

I hope you understand what I mean :) and thank you for the help!!

 

Werner 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Werner

 

Sorry to hear about your problem. I do not know Gunter's LUA Scripts you refer to and will leave him to answer that. However, I assume from your signature that you are using the latest Aerosoft Airbus A318/A319/A320/A321 release with LINDA 2.5.7. What hardware are you using?

 

If my assumption is correct, I would recommend you try the latest Airbus module 4.3 which has the functions you require. For the HDG, the functions are Autopilot_HDG_managed and Autopilot_HDG_set. Make sure that you change the aircraft module folders to Aerosoft Airbus in both \fsx\modules\linda\aircrafts\ and \fsx\modules\linda-cfg\aircrafts\.

 

I hope this helps.

Share this post


Link to post
Share on other sites

Hi Scotflieger,

you're right, its the newest Airbus series from Aerosoft. As Hardware, i am using a Self made glaershield with almost 50 functions.

 

I am using the latest Linda software, and know the functions, but they work only on a rotarie knob, not on a push/pull knob. Is this correct?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi Werner

The Autopilot_HDG_managed and _set function can be applied to a push button. On the Airbus FCU panel I assign 'managed' to push the knob and 'set' to a small adjacent button. If you have a knob that can be pressed and pulled you can assign them as per the real Airbus. You will find the rotary functions under the AP Rotaries section.

 

Here is a list of all Aerosoft Airbus 4.3 functions.

Edited by ScotFlieger
Added Function List link

Share this post


Link to post
Share on other sites

Check that your hardware is talking to FSUIPC. If it can't see the knob push then LINDA will not.

Share this post


Link to post
Share on other sites

Hi Werner

 

I am not sure what to suggest that you haven't already tried.

 

I would look at the following possibilities:

 

  • Does the button line highlight in the Joystick page for your device when you press your knob?
  • Does assigning the managed/set functions to other buttons work correctly?
  • The original scripts you mentioned toggled between managed and set. These functions are single action. Have you considered that?

Perhaps you can send me the linda2.log file (in modules) and a screenshots of the joystick setup page and joystick programming page.

Share this post


Link to post
Share on other sites

Thanks again for your help. I'll try some things and give you a call, if I need your help.

Caio,

Werner

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this