Sign in to follow this  
Asamra

NGX update

Recommended Posts

hi

 

i bought the NGX with expansion on 8 Mars 2015, do i need to instal the update SP1D also??

 

thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

hi

 

i bought the NGX with expansion on 8 Mars 2015, do i need to instal the update SP1D also??

 

thanks

If you downloaded the NGX from PMDG on March 8, 2015 you don't need the update. RSR announced the update on March 5, 2015. Downloads from PMDG after that date would include SP1D. So you are current. You don't need anything.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this