Sign in to follow this  
WillsB3

Help with setting up NE

Recommended Posts

Hi,

 

I finally purchased Night Environment British Isles. I've been playing with it and testing some settings but I can't get things to look right. I'm using MegaScenery Earth England and Wales, Orbx Global + Vector. Here's my scenery library: https://drive.google.com/open?id=0B012srY358MYcFhJUE9QY3hFQmc. There are no layers above what's shown that are activated.

 

However, something doesn't look right. The ground splash looks totally opaque. See this screenshot: https://drive.google.com/open?id=0B012srY358MYRE1aYWJYRFB3VWc. This does not look correct to me. I've been looking at the simply stunning screenshots in the NE France Thread and it looks very different.

 

I could not use Level 0 to remove the groundplash but that's not ideal as the manual says: https://drive.google.com/open?id=0B012srY358MYbmdDY0pEckplSG8

 

I'm using P3D 2.5. 

 

I've checked the manual but seem to be following all recommended steps there. Have I done something else incorrectly :)?

 

Many thanks,

 

Wills

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Willis

in general; i suggest moving NE scenery above UK2000; or any other daytime Photoreal

(if some areas don’t show our night splash; there might be a bgl file blocking it

you may need to manually trace it and deactivate it; in the original Photoreal set;

not saying this is the case; just FYI)

 

You also need to reverse the order your NE scenery is layered

(in P3D make sure the physical base folder has the word P3D in it;

reverse logic for FSX, as both folders exists in root while only one required for each platform with the rest)

 

Base is at the top

Zero

One

Two

Three

 

Then move the group above any existing PR sets you own

 

 

under P3D the colors in my opinion are more realistic and closer to what we intend with HDR set to OFF

we also found that tessellation effects the night brightness as well; and is recomended to switch to OFF or 0

(don’t ask me why; the function is unrelated yet it does change the night look generaly)

 

i strongly suggest calibrating your monitor, first through the physical built-in monitor controls

then through windows controls (under display settings > calibrate colors)

when running the windows wizard; in specific pay attention to gamma adjustments;

as this will greatly affect your night view color intensity, wash, and softness

 

I can’t stress that enough; proper monitor calibration is crucial for night flight,

further more correct Gamma adjustments is critical for any night scenery

 

some of the points i mentioned are usually unnoticeable during the day due to the amount of light;

at night these make a huge impact on visuals!

 

Let me know how this worked out

Share this post


Link to post
Share on other sites

Hi Chris,

 

I've moved NE above all my UK scenery now as suggested. I also tried disabling HDR but didn't notice any improvement in the light splashes "harshness". In addition I experimented with calibration but again no difference to the issue I'm seeing.

 

The reason I think what I'm seeing is not correct is because in the previews I've seen of other NE products (like the quite simply incredible looking shots here http://forum.avsim.net/topic/445103-aerosoft-night-environment-france-preview/page-4). The light splashes in these preview images blend in with the ground significantly more than mine. Almost as if on my system there is no alpha/transparency blending going on with the light splash textures. For example see another shot of what my simulator looks like (this time with Levels Base, 0 and 3 enabled: https://drive.google.com/open?id=0B012srY358MYc0RjX0s3NHQ3WDg. As you can see the light splashes are what appears to be fully opaque white/orange, unlike the nicely blended ones as shown here for example.

Share this post


Link to post
Share on other sites

its little clearer now the issue you’re seeing; i agree the blending not right there

few things to consider though when comparing the images you posted
the first is shown with Photoreal below NE (a normal day time PR)
our splash effect blends with what’s under it; then reflects the blended colors back
you will get an array of splash tones when the ground below is dark the where its lighter

the second image is not shown with any Photoreal under NE; it’s shown against the default textures
therefore it greatly depends what textures are currently placed under NE in a given location

with that said i still think this is not displayed right on your system; even against the default textures
can you share some of the settings and hardware specs you currently running?

these were just snapped in P3D 2.5 here on my system; no Photoreal in these shoots, just default
control V and converted to JPG for posting, no edits or any manipulation are ever made with any image we post
(because i develop on these machines; they are always kept barebones default)
this is how it should look against the default texture in P3D


2015_3_21_15_11_58_585.jpg

2015_3_21_15_13_42_325.jpg

Share this post


Link to post
Share on other sites

I also tried disabling HDR but didn't notice any improvement in the light splashes "harshness". In addition I experimented with calibration but again no difference to the issue I'm seeing.

your response leads me to believe there might be an issue with your P3D itself,

I can suggest a procedure for you to try; I can’t guarantee it will fix this particular issue;

But It's what I’d do in your shows; reset your P3D user profile,

You do this by deleting Lockheed Martin folder, in %AppData%\ (put this on the run line, and hit enter)

after that; start P3D again

 

At this point when you start P3D the first time

if you are asked a question by P3D, Huston we have a problem!

 

This usually means your hardware isn’t up to par with P3D requirements

Answering yes to this question will have P3D try to run a down-level hardware profile with P3D

(that’s permanently until this process is performed)

Not all function are supported under this profile; as it downgrades to DX10;

which eliminates many of the advance features P3D offers and need for proper operations

 

you can read about down-level hardware here

http://www.prepar3d.com/SDKv2/LearningCenter/getting_help/getting_help.html

(scroll to Troubleshooting Video Card Support section)

 

You should always answer ignore to that question; if you didn’t answer ignore and hit the yes instead

to have your machine profile reevaluated you will need to delete your current user profile as I mentioned above

and run P3D again; and hope you get DX11 compatible profile with your new hardware

in any case do not answer yes to the prompt, hit ignore!

 

this also hold true when upgrading hardware with P3D,

if you’re locked on down-level hardware profile P3D will not know you upgraded until this process is performed

Share this post


Link to post
Share on other sites

Just taken some new shots. I can't use the default P3D textures because I have FTX global installed which overwrote them. These are with FTX England (with Global and Vector installed and "Europe" selected in FTX Central V2) and NE British Isles after I'd renamed my %APPDATA%/Lockheed Martin folder:

 

https://drive.google.com/open?id=0B012srY358MYWS1ocF9SYm1JVUk&authuser=0

 

https://drive.google.com/open?id=0B012srY358MYbzhzOFRhYVllY0E&authuser=0

 

These were taken right near EGFF. I believe the second image is of Cardiff itself. As you can see the patchy problem remains :/

 

These were taken with stock graphics settings as when I removed my %APPDATA%/Lockheed Martin folder a fresh Prepar3d.cfg was obviously generated. All I did was increase the frame rate limiter. No other changes were made.

 

It's not a hardware issue. As you can see here my system usually runs P3D well. The specs of this self built rig are:

 

Cosmos 2 Chasis
Corsair AX860 Modular PSU
Gigabyte GA-Z87X-OC
Intel Core i7 4770K (@4.4GHz)
16GB Corsair 1866Mhz Memory
Geforce GTX770OC 2GB
Sound Blaster X-Fi Titanium
1x 256GB Samsung Evo SSD (Windows 7 + PREPAR3D).
1x 256GB Samsung 840 SSD (Windows 8 + All non-PREPAR3D software).
 
There's definitely something fishy going on here. I'm running the latest P3D (2.5 with both hotfixes installed). I assume this should not cause any issues?

Share this post


Link to post
Share on other sites

2.5 is fine as you saw from my pics,

this looks little different to me; did you try switching HDR and tessellation off, noticed any diffrance?

Share this post


Link to post
Share on other sites

i don’t think NE is at fault here; just being affected by this condition;
i can suggest another procedure that may or may not solve this issue (it can’t hurt)
clear scenery indexes then flush DX cache; if first step didn’t help

go to C:\ProgramData\Lockheed Martin\Prepar3D v2
and delete everything in there; accept Scenery.cfg
this will force P3D to rebuild its scenery index

if this did solve the issue; try this next; go to
C:\Users\UseName\AppData\Local\Lockheed Martin\
and delete Prepad3D v2 Folder

Share this post


Link to post
Share on other sites

Hi Chris,

 

Just tried both of those suggestions and no luck. I have noticed if I use the Time Preview feature of P3D and set the time to *just* after the lights turn on they look perfect. Adjusting the slider towards later times makes the ground splash become more visible and move towards being overbright again. I've recoded this into a video so you can see what I mean which is just uploading (I have a slow connection so it'd be an hour or so.. I'll post the link here when it's uploaded.)

 

Additionally, with Base 0 disabled in the scenery library everything looks great (except no ground splash from NE of course but there does appear to be some from of groundsplash perhaps part of FTX England's base textures). The fact that by tweaking the time I get the lights looking as I expected suggests that it's not a fundamental issue with my P3D install to me but I'm not sure what your thoughts are on this?

 

P.S Many thanks for the help and suggestions so far. Great support especially as it's the weekend :)

 

Hope we can get this issue resolved soon as now I've seen how great it looks (even if I did have to set the exact time) I can't wait to explore the night!

Share this post


Link to post
Share on other sites

i feel you Wills
it doesn’t sit right with me knowing even one of our customers is not having the experience intended
 
just by elimination; since a condition exists where NE is presented correctly by P3D
I’m still not 100% convinced that P3D is fault free yet; but it does present another lead
are you on the latest driver for graphics?

Here’s a last shoot repairing this
If this doesn’t work; we will take it to LM for further assistance
 
This may hurt a bit; but needs to be done for proper operation
You will need to delete your scenery.cfg and rebuilt it (don’t despair yet; you may have a none manual alternative; read on)
In previous steps we deletes everything in %APPDATA%\Lockheed Martin\Prepar3D v2 accept scenery.cfg
Scenery.cfg can get corrupted; especially when adding and shifting scenery around
 
If you open scenery.cfg in a text editor; scroll all the way to the bottom
Then inspect the last few scenery entries [Area.xxx]  and Layer=xxx for each scenery entry
These first should match each other
In addition; the scenery layer order need to be sequential like this
 
 

[Area.122]
Title=Langley_AFB
Local=Scenery\Cities\KLFI_Langley_AFB
Layer=122
Active=TRUE
Required=FALSE
 
[Area.123]
Title=FortRucker
Local=Scenery\Cities\FortRucker
Layer=123
Active=TRUE
Required=FALSE
 
[Area.124]
Title=Bathymetry
Local=Scenery\Bathymetry
Layer=124
Active=TRUE
Required=FALSE

 
If any of these are broken or disturbed in youe scenery.cfg; you will get scenery anomalies
 
To fix this the easy way
I noticed you are using SceneryConfigEditor
This makes life easy; but im not sure how it performs with P3D; with FSX this will solve the problem 10 out of 10
Open SceneryConfigEditor, load P3D scenery.cfg
Then go to Action > Reset area and layer numbers and reorder the file
Save your changes; at this point id repeat the step of deleting everything
In  C:\ProgramData\Lockheed Martin\Prepar3D v2 accept Scenery.cfg
 
open Scenery.cfg again and confirm visually that scenery layers are correctly layered
start P3D and cross your fingers

Share this post


Link to post
Share on other sites

Hey Chris,

 

Here's the video: 

 

I'll try your last suggestions next and let you know how it goes.

 

Many thanks

Share this post


Link to post
Share on other sites

Everything appeared to be in order with the scenery.cfg but I ran the suggested tool from within FS Scenery Configurator, cleared my C:\ProgramData\Lockheed Martin\Prepar3D v2 folder (except scenery.cfg) but still no change.

 

I'm not on the latest drivers. I'm on 344.65 (released Nov 2014) as I've found all the later drivers I've tried give me microstutters in P3D. I'll try the very latest drivers next as a test just to eliminate that avenue however.

 

Will report back shortly.

Share this post


Link to post
Share on other sites

Thank you for that Willis

it does demonstrate the lighter effect you noticed, but...

it’s not technically right; moving the slider to time of day when the blending is more subtle/softer

isnt the right solution or shows the right view on your machine

the blending is still not right

 

it was brought to my attention by one of our team member that this happened to his machine (one of them)

i quote part of his response

"it's related to tessellation ability of the graphic card; with a weak one, tessellation disabled works fine (nevertheless the sim locks after five minutes, but it works).

With a decent graphic card, tessellation enabled (and slider put where it has to be) we get the same results as in FSX; that's it."

 

i strongly suggest turning off Tessellation again, this time closing P3D then turn it on again

for tessellation to switch on or off you must exit P3D first

Share this post


Link to post
Share on other sites

No change with latest Nvidia driver.

 

I did restart the sim last time I disabled tessellation but will try again. I would say that GTX770 should be more than fast enough for this right... I mean you must have many customers running P3D on much worse GPUs?


Here's a shot with Hardware Tessellation completely disabled (having restarted the sim): https://drive.google.com/open?id=0B012srY358MYaE1KdHVMeXVqSGM

 

I notice that the colours are different (more yellow and less orange) but other than that it still looks incorrect to me?

Share this post


Link to post
Share on other sites

im running with GT525 (Tesselation is disabled and HDR)

with 9.18.13.3165 drive from 2013

Share this post


Link to post
Share on other sites

we did just about everything i can think of

you’ve reset your scenery and setting twice now,

 

we did the full circle; time to bring this to LM's attention

i suggest starting a support request thread on their forum; give them time to catch the thread

i will chime in to offer any information needed to help figure this out

Share this post


Link to post
Share on other sites

we did just about everything i can think of

you’ve reset your scenery and setting twice now,

 

we did the full circle; time to bring this to LM's attention

i suggest starting a support request thread on their forum; give them time to catch the thread

i will chime in to offer any information needed to help figure this out

 

Excellent, thanks Chris. I'll create a thread there with as much detail as I can. I'll drop a link here for reference too.

Share this post


Link to post
Share on other sites

Thank you very much Willis

you can use the images from my post to help illustrate the issue

(if you quote my post with the images; you will have the links ready to post ;) )

 

In technical lingo; this is a Photoreal night layer that remains opaque

This will likely happen with any Photoreal night layer on your machine atm

Share this post


Link to post
Share on other sites

Thank you very much Willis

you can use the images from my post to help illustrate the issue

(if you quote my post with the images; you will have the links ready to post ;) )

 

In technical lingo; this is a Photoreal night layer that remains opaque

This will likely happen with any Photoreal night layer on your machine atm

 

 

Thanks Chris,

 

Here's the link: http://www.prepar3d.com/forum-5/topic/issue-with-night-environment-possible-3rd-party-scenery-issue/.

 

Just wanted to clarify, in all but the original test I was running only Orbx scenery. In the initial post I mentioned I was using MegaScenery Earth England and Wales (which I was) but I then disabled this as I thought it might resolve the issue (but it of course didn't, so all the shots/video you've seen has been of Night Environment on top of Orbx Wales.)

 

Thanks again for your assistance with this, let's see if LM have any gems of information they can share with us :).

 

Enjoy the rest of your weekend,

 

Wills

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this