Sign in to follow this  
houstonhear

Cannot change FSX installation folder

Recommended Posts

Hi, guys:

 

I just transferred FSX to a new, dedicated SSD. 

 

Consequently, I went into FSI Server configuration to change the installation folder from C:\FSX to E:\FSX.   When I exit the configuration page, I got the message, "Configuration Details Changed. . .", so I figured all had gone well and then exited FSI and restarted.  However, when I went back to check, FSI configuration still showed C:\FSX.  It did not save the change that I made.  I tried this several times, both using the browse button and manually entering the new location, but neither method worked.

 

I also tried it in FX Opus.  It made and saved the change with no problem.

 

Any ideas what I might try next?

 

Thanks in advance for you support.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Looks like the program cannot save the new data to disk...

 

Make sure OpusFSI is installed in its own root drive (e.g. c:\OpusFSI) and in only one location, or on one drive.

 

Check the sharing and permissions for your OpusFSX installation folder and drive, and even for the FSISERVERCFG.DAT file.

 

You could even try deleting your FSISERVERCFG.DAT file just in case that file is locked (you will have to configure it again).

 

Also shutdown any Anti virus program that could be blocking file access.

 

Let me know how you get on.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Well, I solved the problem, but it was really odd.

 

I found a second OpusFSI folder inside of the C:\OpusFSI one.  It appeared to have a complete program.  I opened FSIServer from there, was able to change to E:\FSX.  I then closed that program and re-opened FSIServer in C:\OpusFSI.  It was properly changed there, also, to E:\FSX!  I then deleted the inner folder and everything appears to be functioning correctly now.

 

I have no idea how that happened, unless at some point I failed to uninstall before installing a new update somewhere along the way.

 

In any case, problem solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this