Sign in to follow this  
soaring_penguin

airfoillabs cessna 172 v1.40 linux bug and solution

Recommended Posts

I reported this bug to Airfoillabs, but I wanted to share the solution.

I run X-Plane under linux, and after entering the serial key, the simulator crashed immediately with a SASL error.
In the end, I figured out it was a problem with the naming of one of the plugins, Linux reads the capitals as different characters in file names (as it should be).

 

The error message: 

[sASL ERROR] can't load component p_FVent
[sASL ERROR] Error loading panel: [string "/home/papa/X-Plane 10/Aircraft/General Aviati..."]:0: attempt to call global 'p_FVent' (a nil value)
--=={This application has crashed because of the plugin: SASL}==--
 

So I renamed in : 
Airfoillabs C172SP 1.40/Custom Avionics/p_FVent/

   p_Fvent.png and p_Fvent.sec to p_FVent.png and p_FVent.sec
after which the simulator did not crash anymore.

I hope this helps anybody. 
I tried to post this on the .org as well, but I am not allowed to make new topics there.

Jan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this