Sign in to follow this  

Saitek, Windows 10, USB 3.0, and Advanced Power Management

Recommended Posts

New revelation.  Last night I did some "experimental" flying.  I had noted that with the new Windows 10 system I recently built my Saitek Pro Flight Cessna Yoke and Pro Flight Pedals now work fine when connected to an external powered USB 3.0 hub. With my previous Windows 7 system and with a separate Windows 7 laptop, the same Saitek controls would not work reliably if connect to any USB 3.0 port.  That issue had also been reported by a number of other users.  So having seen the difference I decided to again try plugging my Saitek Multipanel directly into a port on the USB hub on the back side of the yoke. Another connection that would just not work before  with either my previous system or or the separate laptop.  I did and now it works beautifully.


Never worked well before? Ha! In fact if the Multipanel was connected to that hub on the back of the yoke. if it worked at all it was dismal and would always loose power during flight. And the problem actually got worse if I used the accessory power supply for the yoke.  Always had to plug the Multipanel directly to the computer to get it to work. 


With these two issues seemingly resolved I can only guess that Windows 10 has (a): better management of USB 3.0; (b) has more reliable control via Device Manager of Windows Advanced Power Management (which I had to fix with Registry edits for the Saitek devices back in Windows 7); © that the newer Spad.Next driver I use to drive the Multipanel is making a big difference; or (d) contributions from all of the above. 


Bottom line is that now for the first time I can connect the Saitek yoke and pedals to a conveniently powered USB 3.0 hub on top of my office desk; and I can reliably connect my Saitek Multipanel to the hub on the back of the yoke. Now making a good improvement in my cable management, and in my flying!


All is still not perfect. Under Windows 10 I cannot start my system with any of these Saitek devices plugged in --or-- unplug any of these Saitek devices before shutting down my system without freezing my mouse. So I have to disconnect them in order to boot the system, plugging them in after the system is up and running; and after flying I cannot unplug them before I shut down the system. Yet another checklist!

OK. A long Avsim lag made it appear that my first attempt to post had failed. So would a moderator please delete the duplicate?  Thanks!

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this