Sign in to follow this  
tamsini

How to use OpusFsx with P3D v3 new structure?

Recommended Posts

Hello all, is anyone having the same problem as me with OpusFSX and the new structure in v3? Example, with RealAir's Turbo Duke, since it is installed outside the main P3D folder, OpusFSX does not "see it" in order to configure the cockpit views. Is it perhaps just OpusFSI that is compatible?

 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

OpusFSX is not fully compatible with p3d v3 as there are many changes including third party install folders. For p3d v3 you must use OpusFSI Beta version 4.62.12, see our SimForums Announcements and even the latest beta Announcements here.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Hey thanks Stephen for the incredibly quick response!  Did you mean to provide a link by any chance?

Share this post


Link to post
Share on other sites

Here's our SimForums Announcements...

 

http://www.simforums.com/forums/announcements_topic42608_post339747.html#339747

 

Hopefully we've reached the end of the OpusFSI betas for p3D v3 compatibility. Our avsim Announcements are at the head of the topics, announcing availability of the latest .12 OpusFSI beta. The formerOpusFSX product is really best suited to FSX, FSX-SE, and P3Dv1. P3D v2 introduced many SimConnect handling problems inside the sim, hence we developed the OpusPDK Interface for better Live Camera and DHM control. P3D v3 has many changes and a few SimConnect errors, one requires a different weather injection procedure which may only be needed temporarily until LM fix one of the SimConnect function errors. We've been through several OpusFSI betas to achieve the current P3D v3 compatibility. So if you want to use the latest P3D sim you should be using the latest OpusFSI beta. It has all the necessary mods including support for additional SimObject airplane and rotorcraft folders.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Stephen I have tried installing both my registered version of OpusFSX and then tried an eval of OpusFSI. Both are giving me this error message:

 

 System TypeInitializationException. This type initializer for d thre an exception, 

----> System ID.IO.FileNotFoundException. The specified module could not be found. Exception from HRRESULT:(0x800700E)

at d.cctor()

End of inner exception stack here

 

Which to me translates to: HEEEEEEELLLLLPPPP!!!!!!!!!!!

 

Regards, Mario

Share this post


Link to post
Share on other sites

See FAQs .. You do not have SimConnect installed. LM do not install SimConnect when you install p3d. Use our SimConnect.msi, you may even need to create a SimConnect.xml file in your p3d AppData folder. You will find a default one in your new OpusFSI folder.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this