Sign in to follow this  
emann072

ASN SP3 on client PC - Error Cannot load Simconnect upon Win10 Upgrade

Recommended Posts

Hi,

I was running Active Sky Next SP3 on network confirguration with Win7 on a laptop and FSX with Acceleration on a server PC. Everything works normally.

This week I have upgraded to Win 10. I have reinstalled Active Sky Next and then SP3 and placed the original simconnect.cfg file in the documents folder. I have configured all the files and I can see all the files from ASN related to location of FSX on the server. Upon loading ASN I am getting an error as follows:

Cannot load SimConnect

Unable to load any managed SimConnect interface. Simulator Connectivity is not possible. Please check your simulator/SimConnect Installation

Below is my simconnect.cfg file:

[simConnect]
Protocol=IPv4
Address=192.168.0.112 
Port=6600 
MaxReceiveSize=8192
DisableNagle=1

Any assistance appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Make sure your simconnect.xml on FSX/P3D side has the same configuration:

<?xml version="1.0"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.0.112</Address>
      <MaxClients>64</MaxClients>
      <Port>6600</Port>
      <MaxRecvSize>8192</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>
</SimBase.Document>

Connection should be automatic. Also, make sure you have network access between the PCs, easily checked with a PING command.

Share this post


Link to post
Share on other sites

Hi,

 

thanks for the reply...But I did not touch anything in the xml file on the server where fsx is running...the change was an upgrade to win 10 on the laptop and reinstalling ASN...I kept a copy of the simconnect.cfg and placed in the documents folder, remounted the drives of the server, identified the folders in ASN and tried connecting...

 

as soon as I open ASN i get the error.

 

Are you using ASN on win10 in networked configuration by chance just to ensure that such a setup is possible.

 

thanks,

emann

Share this post


Link to post
Share on other sites

Nope, both run Windows 8.1.

 

Might be the firewall settings (i don't use the firewall). It should be possible on windows 10 nevertheless.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this