Sign in to follow this  
Dillon1431

Landing Gear randomly drops in NG

Recommended Posts

Hi, whenever I depart, like 10 min into the cruise the landing gear drops in the NG randomly. Anyone know how to fix?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi, whenever I depart, like 10 min into the cruise the landing gear drops in the NG randomly. Anyone know how to fix?

 

Usually means you have a key on your hardware assigned to the gear and it's sending errant signals. I used to have this with my Saitek X-55 until I installed the drivers specifically for FSX, FSX:SE and P3D. If it continues, unplug the hardware and plug it back in to clear any errant electrical buildup on the contacts.

 

Full names in the forum please - first and last.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks how should I fix it, or where should I look in p3d I have the x55 as well?

Dillon Lifrieri

 

As mentioned, you can install the drivers (google is probably the fastest way to find them on their site), or simply unplug the hardware and plug it back in. If you sit and watch the Windows calibration screen (easiest way to get to it is to go to the controls page in the sim and select calibrate) long enough, you'll likely see whatever button you've assigned to the gear light up red randomly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this