Sign in to follow this  
homer99

747 400

Recommended Posts

hiya there I have flight simulator x steam edtion I would like to know do I need service pack 1 and 2 or not.

and also could please tell me how install it get it working please

kind regards thank you

colin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Colin,

 

The 747-400X is not compatible with FSX Steam.  For use with FSX DVD Edition the SP2 update or Acceleration Pack are required.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this