Sign in to follow this  
morten7741

Black squares in P3D V3.1

Recommended Posts

Hello again.. So I've now got another problem with P3D, a few days ago when I looked for an outside view when I was in cruise flying, instead of having normal contrails I had these weird black squares as P3D couldn't find any textures for the contrails, I've read some other posts about this and thought it might be because I was missing some files in my effects folder, so I checked for the smoke fx and they were all there.. I even got to the point where I installed FSX again and tried to copy the files from there though without any luck. I've just tried to repair my P3D still with no luck, i'm really clueless right now about what to do, but I can still fly with it, it is just really annoying.

 

This also happens if I get a fire on my engines or as I said when I have contrails. I thought it had something to do with fsfx preciptfx but it didn't (I have fsfx preciptfx all the immersion packs for the 777, a320 737 ngx. I don't remember uninstalling any addon that were designed for FSX the last couple of days, although I may perhaps forgot something.

 

 

Best regards

Morten

 

Thanks

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

The only solution I know of is to make sure you have fx_1.bmp dated 7/2/2015 in your P3D Effects/Texture folder.  The FSX version is dated in 7/26/2006.  Same goes with fx_smoke.bmp.

 

Some aircraft have special effects installed just for their aircraft. For instance I think some Carenado aircraft have their own smoke effects.  When you replaced the effects with the FSX, you might have overwritten those that were installed for other aircraft or scenery.

 

Best regards,

Share this post


Link to post

Yeah, that's what I thought.. Can I actually download those files somewhere? Because I don't know where else I should get hit from.

 

 

Thanks

Morten

Share this post


Link to post

Just checked if I had the files with the date, and I did.. So what could be causing it now? 

Share this post


Link to post

I literally have no idea of what I could do? Is a full reinstall the only option now?

Share this post


Link to post

You stated you did a repair for your installation of P3D so uninstalling/reinstalling will have no effect.  It's one of your add-ons that is causing the problem.  I suspect FSFX.  If there is no way to disable your add-ons, then you will have to uninstall them until you find the one that is causing the problem. 

 

Did you know you can bring P3D back to the default installation?  You move the p3d.cfg and scenery.cfg to a temporary folder.  If you have a dll.xml or exe.xml, you move those too.  Now restart P3D.  This will return your installation to the default.

 

Best regards,

Share this post


Link to post

Im going to try to uninstall the FSFX producs to see if that is causing it, if not then I will try to delete my cfg's etc, thanks very much, I will come back.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this