Sign in to follow this  
Q400lover

X52 pro not being recognized and freezes

Recommended Posts

So I'm trying to install my X52 pro flight stick and every time i run the driver installer and get to the point where it asks me to plug it in it doesn't recognize it and I can't click next. A few time I go it to recognize it and it freezes my pc and I have to shutdown my pc via the power button because even control alt delete doesn't work when it freezes, I have even waited about and hour before I shut it down. I m plugging it into a 2.0 sub instead of a 3.0 and I have tried every USB port and the same thing happens any ideas?

Motherboard - Gigabyte Z170XP-SLI. 
Processor - Intel Core i7-6700K 4.0Ghz 4.2Ghz turbo. 
System memory - Vengeance DDR4 16GB (2x8) 3600Mhz. 
System type - 64-bit operating system. 

Storage:
500GB Samsung 850Evo SSD. 
2 Western Digital 1TB 7200RPM HDD Black Edition. 

Graphics:
NVIDIA Geforce GTX 660 Superclocked. 

Cooling:
Corsair Hydro H55 liquid cooler. 
Aero Cool DS 120mm Black Cooling Fan. 
One other fan. 

Powerplant:
Thermaltake Smart M750W 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Had the same problem. Try this.

 

1) Install the most recent driver and when you get bored waiting at the 'plug it in' prompt cancel out.

2) Reboot

3) Go into your devices and look for the controller. It may or may not be showing an error

4) Right click on the entry and manually update the driver

5) Choose a driver (not letting it search) and pick the generic USB controller option (not the one that says it's for the X52).

 

This worked for me.

 

Good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this