Sign in to follow this  
realkewl

Configuring OPUSFSI 4.65.6 beta and Prepar3d 3.3 Permission issues still

Recommended Posts

I am trying to setup OpusFSI with my Prepar3d and I have shared lockheed martin folder as well as the weather theme folder. I have granted everyone permission from the root of Lockheed Martin folder on down. Theme folder is shared to everyone and permissions granted to everyone, full control. I have run OpusFSI as Admin and I'm still getting the cannot find folder check permission.

 

In OpusFSI I selected Lockheed Martin as my sim and path as Lockheed Martin, then tried the theme folder still get the error.

 

Thanks,

RealKewl

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First, try sharing the entire install drive, then make certain you have 'added' an Everyone 'user group' to both the sharing and security permissions granting Full Control to the group in both instances. You may need to create an Everyone user group.

 

Also make sure you do not have any Anti virus program, including Win 10 Defender, active. Any AV program must be shut down. Trusting FSISERVER is usually not enough as an AV program will still block access.

 

Finally make sure you have identified the actual 'root' install folder for the sim in the FSISERVER Config.

 

Stephen

Share this post


Link to post
Share on other sites

Ok I'll try first sharing the whole drive. You said everyone user group. Do you mean 'User' or 'Group'. Right now i have the user 'everyone' in both sharing and permissions. If I create a 'Group' I will need to have a 'User' belong to that group, correct?

 

Also, disabling the Anit-virus is not an option for me, since this is my only computer. If plan A does not work is there a possibility for a refund? 

 

 

-realkewl

Share this post


Link to post
Share on other sites

You AV program will most likely block programs like FSISERVER whether you like it or not. You only need Firewall while flying, AV will just slow the sim down and block access to installation folders. You can resume the AV after flying. I'm online all day without AV as I'm not browsing, shopping, emailing, etc..

 

See our GS Guide for details of adding (creating if needed) the Everyone category (or whatever) to both your sharing and security permissions.

 

The software will work just fine if you allow it to ... first you must allow access to your installed sim folder (you're the only one that can do that), and finally you must not run programs that will knowingly block access to those folders. AVs and Flight Sim software are not good bed fellows, all AV programs ruin performance.

 

Stephen

Of course it's up to you whether you want an AV program active while flight simming. You should do what is instructed in the GS Guide and share and set permissions on both the install drive and folder for your sim.

 

Sharing and setting permissions for your sims install 'drive' probably will be enough provided you can stop your other security software (AV program) from blocking access to the sims folders.

 

Stephen

Share this post


Link to post
Share on other sites

<p>Stephen,</p>
<p> </p>
<p>This is very unfortunate. One, I only have one drive and that is the main windows drive, so you cannot set permissions on the whole drive, I'm admin on this machine, and it will not let me changed permission on the program files (x86) folder.</p>
<p> </p>
<p>Also, I really do not feel like disabling/enabling Anti-virus every time I want to fly or do some shopping. The approach granting permission and setting a share sounds more like a patch. Again, this is very unfortunate, because I really liked OpusFSX when I had my FSX machine. But like I mentioned earlier this is a whole new machine.</p>
<p> </p>
<p>Will this every be integrated with Windows 10 and/or Lockheed? Are you talking to Microsoft on a solution? If so, then I can just keep the software until a better approach is available. If refund is not possible then, that is what it is, again this will be unfortunate.</p>
<p> </p>
<p>Also, just an FYI...I changed ownership of the folder for OpusFSI to admin, so you would think they should have admin rights and do whatever they need to do. Also, I changed ownership to Lockheed to everyone. Neither of those approaches work.</p>
<p> </p>
<p>The GS guide says set permissions and share, I don't recall seeing how to do this. Also, the GS seem very vague in this regard. I'm not as technical as you guys are, so creating a new group, I just don't see how that would make it work. Windows uses the most restrictive approach, so even if I grant everyone full control of a folder, if another user exist in that folder (i.e. User) and they don't have full control I will be restricted to the User rights, and not be granted everyone's rights.</p>
<p> </p>
<p>Thanks,</p>
<p>realkewl</p>

 

FYI... I did not put the HTML tags on here...that was avsim, and I do not know how to remove them.

Share this post


Link to post
Share on other sites

You can share and set permissions on your C drive and this will not adversely effect your system. Please step through the section in our Getting Started Guide, share your C drive, the create and add an 'Everyone' user group to your sharing permissions AND security permissions. Note, the Everyone group does not exist normally so may have to be created before adding with Full Control.

 

Alternatively, you could and should have installed the sim outside of the Program Files folder. But doing the above will have no effect on your system. It will simply allow addons like OpusFSI to gain access to your sims folders.

 

It's up to you what you do with the AV but you must ensure it is NOT blocking the FSISERVER program. This is easily done. First do the above sharing and permissions, then see if FSISERVER is ok. If it still reports being blocked or not locating the folder you can then just 'try' shutting down the AV to see if that's the cause before restarting it.

 

You can always email me an image of your FSISERVER Configure dialog along with your sharing permissions and security permissions dialogs so I can check them and assist you.

 

The GS Guide is extremely clear on this and gives you very simple 'step by step' instructions on how to share and set permissions (with screen shots).

 

Changing ownership to Admin does nothing and has nil effect on sharing and permissions.

 

Stephen

 

See...

 

http://www.opussoftware.co.uk/opusfsi/opusfsi_getting_started.htm#_Toc345576860

 

Sharing and Security Permissions

 

Firewall

 

You may need to allow OpusFSI through your firewall. In Control Panel select System and Security, Windows Firewall, Allow a Program or feature through Windows Firewall. Click on Allow another program and browse to FSISERVER (or FSICLIENT on a client PC) in the OpusFSI installation folder.

 

Sharing

 

You may need to set sharing and security permissions on both your OpusFSI and on your FSX (or Prepar3D) folder in order for OpusFSI to write the necessary weather files into the FSX\Weather\themes (or Prepar3D\Weather\themes) folder. This is usually necessary if you have installed the simulator in the Program Files folder, for this reason it is advisable to install FSX in a folder outside Program Files. If this does not work then set sharing and security permissions on your whole drive. Be aware that if you set permissions and sharing on the whole drive then you may have different permissions and sharing on subfolders so make sure you check the OpusFSI and FSX\Weather\themes folders.

 

Absolute worst case, just install FSX or Prepar3D in its own folder (e.g. d:\Prepar3D), moving outside the secured Program Files folder. If OpusFSI still doesn't work correctly after setting sharing and permissions a re-install may be necessary.

 

To set up Sharing on a folder/drive run Windows Explorer, right click on the folder/drive you wish to share, select Properties, select the Sharing tab, select Advanced Sharing, tick the checkbox to share the drive and enter a share name, make sure you use the single letter code, e.g. C, not 'Drive C' for instance. Click on Permissions, enter Everyone in the Group or user names box and tick the checkboxes to allow Full Control for Everyone.

 

Security

 

To set up Security Permissions run Windows Explorer, right click on the folder/drive you wish to set Security settings for, select Properties, select the Security tab, select Everyone in the Group or user names box and ensure the Permissions are Full Control, if not click on the Edit button and tick the Permissions checkboxes to allow Full Control for Everyone. If Everyone does not exist click Advanced, click Change Permissions, click Add, type in the name Everyone and click OK. Then specify Full Control for your newly created Everyone group. Click OK.

 

Also select Authenticated Users in the Group or user names box and tick the checkboxes to allow Full Control.

 

 

N.B.

 

The real GS Guide includes handy screen shots showing the settings.

 

Note,

 

Your changes would have no affect on the situation. Ownership by Admin matters not. Sharing and setting BOTH sharing permissions and security permissions (two separate sets of permissions) on the C drive is what is probably needed. You should do this then if you want after achieving success you can try alter things to be more specific.

 

Sharing and permissions is all down to you. The software cannot override things itself.

 

Stephen

 

Email your Config screenshot etc. to me via,

 

opusfsi@opussoftware.co.uk

 

But do try to share and set permissions on your C drive as this may be the problem and most likely reason why FSISERVER cannot identify or access the sims folder.

Share this post


Link to post
Share on other sites

Stephen,

 

I have gone back over the GS guide and I think I did just about everything, except reinstall.

 

I have done the following:

  1. Granted OpusFSI access through the firewall
  2. created a shared of my whole C drive as the letter 'C', and gave 'everyone' full control of that share.
  3. Gave 'everyone' full control of Opus folder and Lockheed's folder
  4. Disabled Windows defender

I still get the error message.

 

If you're able to trouble shoot with me that would be great. Not sure what time zone you're in but I'm currently in Central US time zone.

 

Thanks,

realkewl 

Share this post


Link to post
Share on other sites

Thanks,

 

Did you try shutting down your AV program before running FSISERVER ?

 

Have you installed OpusFSI in its own 'root' folder, e.g. in C:\OpusFSI.

 

Did you set both the share permissions and security permissions (two sets) on both the drive C and the sims main installation folder?

 

Probably best to screen capture the dialogs and email them to me. Email me a screen capture of...

 

1. Your FSISERVER Configure dialog.

2. Your Advanced Sharing Permissions dialog for drive C with 'Everyone' group highlighted.

3. Your Security properties dialog for drive C with 'Everyone' group highlighted.

 

I will then check them.

 

You can capture the dialog by ...

 

a) Click on the dialog's caption to focus on it.

b) Press on the 'Alt' and 'Print Screen' keys together.

c) Open Window's Paint or select the New option within Paint.

d) Move the mouse cursor into the Paint client area and press 'Ctrl' + 'V'.

e) Crop and Save As a JPEG picture within Paint.

 

My email is,

 

opusfsi@opussoftware.co.uk

 

Regards

Stephen

Share this post


Link to post
Share on other sites

Problem solved after email exchange. Error due to incorrect folder path in OpusFSI configure.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this