Jump to content

Sign in to follow this  
KPBG

Can't Reload LUA Engine with 2.8 in P3D

Recommended Posts

Hi. I just updated P3D, FSUIPC (paid version), and LINDA (new version, thanks!). However, LINDA is not working now. I mean I can see all of my assignments for the Alabeo C404 (copied my backed up folders to the modules folder as instructed in the updated directions), but I can't reload the Lua engine (usually solved any problems I had in the past). Instead, I'm getting a strange error message when I try to reload. The console give me the following message: "[E] *** LUA Error: E:\P3D\Modules\linda.lua:135: attempt to perform arithmetic on a nil value". Thanks in advance for any and all help.  Oh, and I'm using an MCP1 along with custom built switch panels connected via Bodnar boards.

Share this post


Link to post
Share on other sites

Hi. I just updated P3D, FSUIPC (paid version), and LINDA (new version, thanks!). However, LINDA is not working now. I mean I can see all of my assignments for the Alabeo C404 (copied my backed up folders to the modules folder as instructed in the updated directions), but I can't reload the Lua engine (usually solved any problems I had in the past). Instead, I'm getting a strange error message when I try to reload. The console give me the following message: "[E] *** LUA Error: E:\P3D\Modules\linda.lua:135: attempt to perform arithmetic on a nil value". Thanks in advance for any and all help.  Oh, and I'm using an MCP1 along with custom built switch panels connected via Bodnar boards.

Hi, unfortunately there are a couple of issues with the MCP1 panel which I am working on with several users. I will look at LUA Error to identify the cause. In the meantime I suggest MCP1 users revert to the backups you made and use 2.7.0.


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

No worries. Is there something else I can do on my end to get you more data? Also, I did revert back to version 2.7.0 and I've got my buttons working again. Please let me know if you want me to test a new version. Thanks for the quick reply and for all your efforts updating LINDA!

 

p.s. I brought my setup to FlightSimCon in Connecticut a couple of weeks ago and told everyone about how LINDA made it incredibly easy to set up custom panel configurations.

Share this post


Link to post
Share on other sites

No worries. Is there something else I can do on my end to get you more data? Also, I did revert back to version 2.7.0 and I've got my buttons working again. Please let me know if you want me to test a new version. Thanks for the quick reply and for all your efforts updating LINDA!

 

p.s. I brought my setup to FlightSimCon in Connecticut a couple of weeks ago and told everyone about how LINDA made it incredibly easy to set up custom panel configurations.

 

 

Hi KPBG

 

Thank you for promoting LINDA at FlightSimCon and for the offer of support. Please check that you installed the new config-vri.lua file when you installed 2.8.0. This file now contains a new display reset delay value VRI["DELAY"]=xx. You should be able to reset the fault by disabling and enabling the MCP setup. This will write the correct file to disk. Then Reload LUA Engine.

 

Please see your PMs.

Edited by ScotFlieger
Added PM note

Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Thanks for the PM. Disabling then enabling the MCP1 did the trick. Now everything is working again. And, no issues with the MCP1. Thanks again for all your help!  p.s. I just sent along a PayPal donation (long overdue since I've been using LINDA since the early versions : )

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    33%
    $8,485.00 of $25,000.00 Donate Now
×
×
  • Create New...