Sign in to follow this  
threegreen

737 throttle messing up my sim

Recommended Posts

I bought a 737 throttle recently from FSC (Flight Simulator Center) and I can't use it because it messes up my sim. I know it's unlikely anyone browsing this thread will own one too but I'll give it a try. Maybe it's an issue not necessarily linked to this particular developer.

 

After installing the drivers and connecting it to my computer I was struggling to even get it to work in P3D, nothing happened when moving the sliders etc. Then, suddenly, it worked (no idea why). Now about the actual problem: P3D gets stuck randomly while loading a scenario and will take about 30 secs or more to continue. After loading, when I pan the camera around in the VC or outside view it freezes again, awaking from its sleep after 30 or more secs.

 

Perhaps someone with computer/hardware knowledge can work out what's happening. Like I said, I'm hoping that it's some kind of popular occurrence with all kinds of hardware...

 

(Contacted the developer but they don't seem to bother...)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You may be having 2 issues here , does the freezing go away if the device is unplugged?

Share this post


Link to post
Share on other sites

De-installed the drivers and disconnected the throttle and fired up the sim to check - no freezing, everything fine.

Share this post


Link to post
Share on other sites

Out of curiosity have you tried using it on a different USB port IE if you had it plugged into a USB 3.0 try plugging it into a 2.0 port instead? Some hardware just doesn't seem to like 3.0 - especially if it's an older design.

Share this post


Link to post
Share on other sites

I think I plugged it into 3.0 and 3.1 but not in a 2.0 port. The drivers installed some kind of virtual port for the controller.

 

Did a complete reinstall of P3D and tested with a fresh simulator without any addons, same weird things happened so it's definitely the throttle quadrant confusing my sim.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this