Recommended Posts

Hello

 

I just purchased MCE to run with Prepar3d v3.4.9 under Windows 7.

 

All loaded well, however, after going through the voice test, the software requests the location of the P3D.exe and that this be set as administrator. As seen in the forum I have disabled UAC as P3D and MCE are not installed in C drive.

 

The P3D exe is already set to admin but the process continues to open up the P3D folder screen two or three times. After exiting and restarting, a "Could not start splash screen" popup appears. Closing that and starting MCE, a pop states "application already running" and to use the kill process if no MCE window or tray icon.

 

kind regards

 

Laurie

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Welcome aboard Laurie

 

Suggest the following...

 

Check you have fsInsider.dll and <MCE dlls> folder inside \Prepar3D v3\ installation folder.

 

Restore MCE to factory settings.

 

Start->All Apps->Multi Crew Experience->Tools->Restore factory settings

 

That will force you to go through the wizard again. There is no need for speech training if already performed that earlier.

 

If you have renamed "Prepar3D.exe" to anything else (fsx.exe o even P3D.exe, you need to either rename it back to original (Prepar3D.exe), or use this workaround...

 

Open "fsInsider.ini" in \Prepar3D v3\ folder and change "AssumedSimVersion=0" to "AssumedSimVersion=13"

 

Otherwise fsInsider.dll won't know which sim it is running under.

 

I assume you aren't running P3D in compatibility mode (as if running under Windows XP).

 

Start P3D, wait for aircraft to be ready to fly, then start MCE.

 

MCE V 2.6.8 has only been fully tested under P3D V3.5 (without most recent Hotfix).

 

It will eventually be updated to fit very latest P3D release, but might take a couple of weeks.

Share this post


Link to post
Share on other sites

Thanks for the quick reply Gerald

 

Still no luck yet

 

I checked the fsinsider.dll and MCE dll folder is in the Prepar3d folder

 

The Prepar3d.exe is unchanged

 

I was running the p3d in windows7 compatibility mode and run as admin ticked, but I unchecked compatibility mode just in case.

 

I reset MCE to default settings and restarted through the training. At that point after closing the pop up appeared requesting the p3d exe be sat to admin rights, which it always has been and the prepar3d folder opened. Pressing "ok" opened the prepa3d folder again and the admin warning. It does this 3 times before closing down. After that, starting MCE gets the "unable to open splash screen" warning, and starting again is the application already running please use kill process tool.

 

So the process is to start prepar3d then mce, is that correct

 

regards

 

Laurie

Share this post


Link to post
Share on other sites

Correct.

 

You may have "mce.exe" stuck running.

 

Either bring up the Windows Task bar and kill it, or use the provided tool "KillMCE" to do so.

 

Suggest you restart PC and try again.

 

Shouldn't be concerned about the notice regarding running P3D as admin. It's just a reminder in case you forgot.

Share this post


Link to post
Share on other sites

Good morning Gerald

 

I re installed mce just in case of some other issues. P3D is running and I have the aircraft loaded at the airport. When I start MCE I get a popup "could not load splash screen". It appears MCE is running as I have the application already running warning.

 

Is there something else I am doing incorrect.

 

thanks

 

Laurie

Share this post


Link to post
Share on other sites

Good morning Gerald

 

I re installed mce just in case of some other issues. P3D is running and I have the aircraft loaded at the airport. When I start MCE I get a popup "could not load splash screen". It appears MCE is running as I have the application already running warning.

 

Is there something else I am doing incorrect.

 

thanks

 

Laurie

 

I know you mentioned Windows UAC is disabled.

 

I wonder whether you did override folder permissions or things like that.

 

Suggest you un-install MCE via WIndows Control Panel.

 

Save your key somewhere else and delete \Multi Crew Experience\ installation folder if still there.

 

Put the Windows UAC slider back to normal (2 notches up) and restart PC.

 

Perform a standard MCE installation as follows.

 

Run "InstallMCE" and accept the default patch C:\Program Files (x86)\ folder.

 

All you have to do is set "Prepar3D.exe" to run as administrator.

 

Once you have it up and running, up to you if you want to disable Windows UAC again. It's not require though.

Share this post


Link to post
Share on other sites

Good evening Gerald

 

Thanks for the help ,  that worked fine

 

So it appears that MCE prefers default installation only.

 

Wonderful, have a very nice day

 

kind regards

 

Laurie

Share this post


Link to post
Share on other sites

So it appears that MCE prefers default installation only.

 

 

Good day Laurie.

 

Not necessarily.

 

When Windows UAC is disabled, should be able to install MCE anywhere.

 

Be aware, disabling UAC using methods like "registry hack", can result in Windows taking defensive measures, like restricting rights even further.

 

The same applies when you start sharing folders and messing with access rights to folders. Needs to be done carefully.

 

You may assume you're running as admin, but actually aren't

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this