Sign in to follow this  

Yaw control oversensitive - can't adjust.

Recommended Posts

I am using a Logitech Extreme 3D pro to drive FS2004  (Win XP) and I am having trouble with the yaw (Z) axis. It is extremely oversensitive to the point that I sometimes do ground loops before reaching take off speed. I've tried numerous times to calibrate the controller and adjust its sensitivity to no avail. I would like some help in reducing the sensitivity or (perhaps more practically) disconnect the yaw control altogether. I feel using the stick to control yaw is not conventional and I could well do without it. I would appreciate some help with this problem.

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!


We need more information as to the exact problem you're having and have tried.

1.  Do you think this is a Joystick issue or a FS9 configuration issue?
     If you think it's a joystick sensitivity issue, do you use FSIUPC?
     You can adjust the rudder axis from linear to a "slope" within FSUIPC.
     Have you tried this?

2.  Do you think it's a FS9 configuration issue?
     a )  Is it happening in all aircraft?  Some aircraft worse then others?
     b ) Is the aircraft a jet or prop?
     c )  What are your "realism" settings?  P-Factor, Torque, etc.
           Have you tried turning off P-factor?
     d )  Is this a wind vaning problem?
           If the wind speed is set to zero kts within FS9, can you control the steering now?
           Wind vaning in FS2004 is very unrealistic, but can be tweaked if this is your problem.
     e )  Have you tweaked the aircraft.cfg "[flight_tuning]" section line "yaw_stability= 1.0 to see if this helps?

There are many threads on this topic, things to try, but ultimately, you may have to tweak you joystick axis along with a combination of tweaking each aircraft, to find the best solution.

My issue was always the unrealistic "steering" during takeoff with a stiff crosswind. (wind vaning).
FSUIPC has a "Taxi Wind Control" option on the "Winds" tab, but I never liked this option, because it sets the wind speed on the ground to zero.  That said, you can eliminate the wind vaning effect with some tweaking if that is your issue.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this