Jump to content

Sign in to follow this  
Decio Pedroso

Saitek panels displays blinking

Recommended Posts

Hello, LINDA team:

 

Firstly I woud like to congratulate you for this outstand software. Without it, I would send to the trash my 3 Saitek panels and I would never started my overhead panel project.

 

However, since I've upgrated LINDA to 2.8.x releases, my Saitek displays have blinking or even not showing the airplane data. In order to make myself more clear, I have recorded what I have facing so you or anybody else can help me to fix that.

 

Please find the movie at

 

I'm using FSX-SE, SPAD 0.5.1, LINDA 2.8.6 over Windows 10 64bit.

 

Thank you for your support.

Share this post


Link to post
Share on other sites

Hi

 

Thank you for reposting your report. The problem you are experiencing as shown in the video is that both LINDA and SPAD are trying to control the Saitek displays. This leads to the flashing displays. You can only use one at a time. Preferably LINDA should be the only software running so you can use it to assign LINDA functions but it can be slow to change some values.

 

You can disable LINDA controlling the Saitek panels by doing the following:

 

  • Go to Setup LINDA and ensure checkbox Saitek Panels is unticked.
  • Open common.lua (in /modules/linda/systems) with LINDA Editor and search for line containing SAI_DISPLAY = 0 (line 719). Change 2 lines to read:
  1. SAI_DISPLAY = 0                                            (removing '--' prefix)
  2. --SAI_DISPLAY = 1 - ipc.get("SAITEK")         (adding '--' prefix)

Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for your prompt answer.

I've made the changes you suggested but unfortunattely, the blink effect keeps the same.

I can't let SPAD away because the displays, so I wonder a way to effectvely disable LINDA display control.

I will apreciate any other idea you have.

Share this post


Link to post
Share on other sites

I read that you wish to use SPAD instead of LINDA. The 2 settings I gave will stop LINDA controlling the Saitek Multi and Radio Panels.

 

I will double check today that there is nothing else I can suggest.


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Hi, Scotflieger:

 

Actually, after the last LINDA update to 2.9.3 version, I redid the changes on common.lua file you have suggested above and it worked indeed!

This issue is finally fixed because of your support. Thank you.

I just have to add that those changes just got worked after restarting LINDA, SPAD AND FSX.

I think I should thank you and share this with others who can be facing the same issue.

Best regards,

Decio

Share this post


Link to post
Share on other sites

You are very welcome. 


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    15%
    $3,985.00 of $25,000.00 Donate Now
×
×
  • Create New...