Sign in to follow this  
Stefan01

“On Repeat” FS2Crew Softmute lasts too long

Recommended Posts

Hi all

I am extremely happy with Linda and all of its functions.

I have a little problem with the FS2Crew Softmute function when it is “on repeat”. After I released the button it takes 20 seconds till the FO can listen to my commands. This is too long. I presume that this has something to do with the number of cycles the repeat function is repeating this command.

Does anybody know where I can change the program to reduce the mute time after release of the button?

Thanks a lot Stefan

 

My system

Intel i7 CPU X980 4GHz  ;12GB RAM; CSX SSD 1200 240GB x GeForce GTX Titan 376.33  2 screens 1920x1080

 

Software:

Win10.Pro V1607 14393.222 64bit
P3D v3.4.14.18700 PMDG 777 & 738 , FSUIPC 4.959, LINDA 2.8.6 ,IVAP 2.0.2.2773, FS2Crew 777 & 738, RAAS Pro 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I use the library softmute function for FS2Crew for the Aerosoft Airbus when flying with VATSIM/vPilot. I did have an issue where the softmute did not release but for me it releases without any delay. I have not tried it with the PDMG 777 version.

 

Try selecting developer mode and turn on Verbose and LUA. This should show whether the OnPress and OnRepeat functions are being called correctly with Console open.

Share this post


Link to post
Share on other sites

Hi ScotFlieger,

thanks for quick the answer. I think I have found a work around. I have set for this button “on release” “do nothing”

It seems that this interrupts the “on repeat” cycle.

I will check the next flights if this works.

Thanks again Stefan

Share this post


Link to post
Share on other sites

What was the OnRelease set to? Releasing a button should automatically cancel any OnRepeat running.

Share this post


Link to post
Share on other sites

Before it was set to empty, that means nothing was set and you can see the grey word "empty". Now I have set the command "do naothing" and you can see in black the words "DO nothing".

Share this post


Link to post
Share on other sites

I found out that this work arround works only when I do a Reload of the LUA engine  after the aircraft is selected and loaded.

Only selecting the aircraft and run it with the LINDA settings which are loaded together with the aircraft is not enough. In that case the "soft mute" "on repeat" is not interrupted when I release the button.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this