Sign in to follow this  
Rene Scharlach

Default Zoom for OpusFSX Cameras

Recommended Posts

I have a problem with the zoom of the camera views. This is a re-install and I had it working better before, but do not know how to fix it in the new installation.

 

I am setting 0.3 zoom for the pilot view in my PMDG B737 (in "Cameras"), but the camera in the settings shows a very narrow view that is unusable for flying. If I actually use the camera, I can zoom out easily. It will remember even this setting. But 0.3 should be a wider view in the camera settings. So where can I change the default zoom? Is it in aircraft.cfg or in cameras.cfg?

 

I already tried setting the Camera.002 (Virtual Cockpit) to another initial zoom. That worked. But only until I start OpusFSX. Then the zoom is suddenly very narrow. So what do you do to set this zoom?

 

Thanks in advance

 

Rene

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The software has no control over the FOV for any zoom level. It just sets the zoom you specify in the camera edit, assuming these are Live Camera VC views you have created. Note, if you manually change the zoom using the sim commands then the software has no knowledge of this so you must put the zoom back.

 

Always best to adhere to the recommendations in the LC manual. Do not use fine zoom excessively or at all, try and stick to the same or similar zoom levels for view modes. E.g. Use the same zoom level for all panel type views, and the same level for all general VC views.

 

Adjust the eye point to give the view you desire when creating or editing your Live Camera views. Combine this with your desired zoom level. The overall FOV will depend on your display Windows sizing so take this into account.

 

Once more, the FOV has nothing at all to do with OpusFSI. It's all down to the sim. Live Camera does allow you to first adjust all 6 DOF for the eye point and in combination adjust the zoom level to give the desired view. If you manually alter it in the sim then you must manually alter it back.

 

Stephen

 

Also make sure you have installed the latest OpusFSI release version.

 

Stephen :-)

 

Why are you changing the CameraDefinitions for your cockpit views?

 

That's nothing to do with OpusFSI and you should be using Live Camera to create your own VC camera views.

 

Live Camera gives you full control over all 6 degrees of freedom along with the zoom level. So simply create your own VC views (try Importing our example 737 views and editing them). You can create any view(s) you want, assign buttons to them, set your Captains view as the Default and away you go.

 

OpusFSI does not work through the VC CameraDefinitions so don't mess with them.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Okay, Stephen, I understand., but not completely.

 

The problem remains, why I have to set the Zoom in Cameras to 0.3 and still not see any reasonable portion of the cockpit and the window. On my system, zoom 0.3 seems to look different than on yours. Zoom 0.3 here is the minimum, and it is not sufficient.

 

I add an image of what I see when I open the Camera I use for the pilot.

 

krvsdhE.jpg

 

I have not moved the head from the default position of the PMDG B737 at all. In fact, there is no way to get a decent view even if I go back all the way into the cushion. Back in the simulator I can zoom out easily. But the minimal zoom of 0.3 in Cameras is simply not the minimal zoom in the simulator.

 

AlBzDYi.jpg

 

I imported your views, and they are even worse.

 

uleBAUY.jpg

Share this post


Link to post
Share on other sites

Most likely a difference in the default zoom for the vc view mode set in Cameras.cfg in App Data. Could be something changed by LM in latest P3Ds. The addon OpusFSI simply assumes a standard default zoom for each view mode and steps from there. If this is changed then there will be a sync problem.

 

I will look into it and see what can be done tomorrow.

 

Stephen

Share this post


Link to post
Share on other sites

0.3 is the maximum zoom level in the sim.
 
What version of OpusFSI are you using?

Opus cannot read or write the zoom level in FSX. It can only assume a standard default (0.7 for VC mode) then step adjust from there. Check your Cameras.CFG file in <user> AppData Roaming Microsoft FSX. Mine reads as follows...

[CameraDefinition.002]
Title = Virtual Cockpit
Guid = {C95EAB58-9E4A-4E2A-A34C-D8D9D948F078}
Description = This is the description of the virtual cockpit view.
Origin = Virtual Cockpit
MomentumEffect = Yes
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = None
ShowAxis = YES
AllowZoom = TRUE
InitialZoom = 0.7
SmoothZoomTime = 2.0
ZoomPanScalar = 1.0
ShowWeather = Yes
XyzAdjust = TRUE
ShowLensFlare=FALSE
Category = Cockpit
PitchPanRate=30
HeadingPanRate=75
PanAcceleratorTime=0
HotKeySelect=1

 

Stephen

Share this post


Link to post
Share on other sites

Setting this to 0.7 did made things worse. It was actually set to 0.4 before.

 

Note: Once Opus starts, the zoom is set to a narrow view. Then pressing the key for my default view improves things. But I see a much too narrow view, even though that specific camera is set to 0.3. It is not a big deal, since I can zoom out. But setting the cameras is strange if 0.3 shows very little only.

 

This is Steam on Windows 10, by the way.

 

I also installed the most recent version. That made no difference too.

 

Rene

Share this post


Link to post
Share on other sites

It's what the Live Camera views zoom looks like. I have images showing my standard 737 camera views zoomed out to 0.3 and the FOV is very large indeed. I will see if I can post them tomorrow for you.

 

Sounds like there is something seriously wrong with your sim set up. The default zoom level for vc views should be 0.7. If you switch from an opus external camera to a vc view using assigned buttons that will force the zoom level to be reset and stepped to your specified level.

 

What view do you get in this case.

 

Is this only effecting one aircraft type or all aircraft including the stock aircraft vc views?

 

Stephen

 

There has to be something wrong as after opus sets level 0.3 you should not be able to zoom out any further. As I said, 0.3 is the max zoom out in the sim.

 

Have you looked at what zoom level is reported on the display when you select an opus view?

 

Email me your CAM file also so I can use your cameras.

 

You could try re installing SimConnect using our supplied msi file.

 

Also repair FSX Steam in case it's files have been messed up.

 

Have you any other addons that use view or eye point control?

 

Stephen

 

 

Select an opus Live Camera vc view you have created yourself then see what zoom level is reported on the screen.

 

Don't forget to email me your CAM file.

 

Stephen

 

You could also email me a copy of your cameras.cfg and the 737s aircraft.cfg file.

Remember, 0.3 is the MAX zoom out setting in the sim.

 

So ... if you create an opus live Camera vc view with a zoom level of 0.3, select it onto the display, and can then manually zoom out further then that means just one thing.

 

Live Camera was not able to select zoom level 0.3 either by adjusting the zoom or setting level 1.0 and stepping. All adjustments in FSX also done by stepping. Mimicking what you do with the keys.

 

Hence, the default zoom level is not correct on your system.

 

I would do a repair install of SimConnect and the sim unless you can identify what cfg setting has messed things up.

 

Have you been changing settings or installed another addon that may have done.

 

Try the stock aircraft.

 

Check the displayed zoom after selecting a camera view.

 

Try switching to a vc view from an external one using your assigned button or key in OpusFSI.

 

Stephen

Share this post


Link to post
Share on other sites

My images of my standard 737 Captain and Throttle camera views with 0.3 zoom ...

 

PMDG737_Captain.jpg

PMDG737_Throttles.jpg

Share this post


Link to post
Share on other sites

Okay. I have set HideInfoText=0 to be able to see the zoom levels.  Note, that I have also set WideViewAspect=False if that matters in FSX.CFG.

 

I loaded the default Baron for a test.

 

Default View after starting the baron in the VC: 0.3

That is already strange, because in CAMERA.CFG the zoom is set to 0.7 as you recommended. I did not change any file in the Baron configuration.

 

As soon as I start OpusFSX Server the zoom factor of the VC jumps to: 1.0

That has been so ever since I use OpusFSX, and that is quite a long time. It is a nice software.

 

Starting the Camera Configuration Tool, the Zoom sets itself to: 0.6

I have no Camera set for this plane.

 

That is very strange, and I do understand none of this behavior. Attached is my cameras.cfg from the APPDATA/... folder.

 

Rene

 

[CameraDefinition.999]
Title = "OpusFSI External View"
Guid = {01021987-E220-6507-1024-462840738999}
Description = OpusFSI Customized External View
Origin = Center
SnapPbhAdjust = Swivel
SnapPbhReturn = FALSE
PanPbhAdjust = Swivel
PanPbhReturn = FALSE
ShowAxis = FALSE
ShowWeather = TRUE
Category = Custom
MomentumEffect = FALSE
ShowLensFlare = FALSE
CycleHidden = No
PitchPanRate = 30
HeadingPanRate = 75
PanAcceleratorTime = 0
SmoothZoomTime = 2.0
AllowZoom = TRUE
XyzAdjust = TRUE
AllowPbhAdjust = TRUE
InitialZoom = 0.8
InitialXyz = 0,10,-80
InitialPbh = 5,0,0
Track = None
 
[CameraDefinition.001]
Title = Cockpit
Guid = {B1386D92-4782-4682-A137-738E25D1BAB5}
Description = This is the description of the cockpit view
Origin = Cockpit
ShowPanel = Yes
SnapPbhAdjust = Ordinal
SnapPbhReturn = True
PanPbhAdjust = Ordinal
PanPbhReturn = True
Track = None
ShowAxis = FrontOnly
AllowZoom = TRUE
InitialZoom = 0.7
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = TRUE
ShowLensFlare=FALSE
Category = Cockpit
HotKeySelect=2
 
[CameraDefinition.002]
Title = Virtual Cockpit
Guid = {C95EAB58-9E4A-4E2A-A34C-D8D9D948F078}
Description = This is the description of the virtual cockpit view.
Origin = Virtual Cockpit
MomentumEffect = Yes
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = None
ShowAxis = YES
AllowZoom = TRUE
InitialZoom = 1.0
SmoothZoomTime = 2.0
ZoomPanScalar = 1.0
ShowWeather = Yes
XyzAdjust = TRUE
ShowLensFlare=FALSE
Category = Cockpit
PitchPanRate=30
HeadingPanRate=75
PanAcceleratorTime=0
HotKeySelect=1
 
[CameraDefinition.003]
Title = Spot
Guid = {BCA3FDD1-FB83-4BBA-8407-4922A7F0D00C}
Description = This is the description of the spot view.
Origin = Center
SnapPbhAdjust = Ordinal
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = FlatChase
ShowAxis = No
AllowZoom = Yes
InitialZoom = 1.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = Yes
ShowLensFlare=TRUE
Category = Outside
ClipMode = Spot
PitchPanRate=30
HeadingPanRate=75
PanAcceleratorTime=0
 
[CameraDefinition.004]
Title = Locked Spot
Guid = {BCA3FDD1-FB83-4BBA-8407-4922A7F0D00D}
Description = This is the description of the spot view.
Origin = Center
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = FlatChaseLocked
ShowAxis = No
AllowZoom = Yes
InitialZoom = 1.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = Yes
ShowLensFlare=TRUE
Category = Outside
ClipMode = Spot
PitchPanRate=30
HeadingPanRate=75
PanAcceleratorTime=0
HotKeySelect=3
 
[CameraDefinition.005]
Title = FlyBy
Guid = {6B79DD49-9B4A-439D-BF40-ACBF157B0BA0}
Description = This is the description of the fly by view.
Origin = Center
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = FlyBy
ShowAxis = No
AllowZoom = Yes
InitialZoom = 10.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = No
ChaseDistance = 500
ChaseHeading = 15
ChaseAltitude = 10
ChaseTime = 20
ShowLensFlare=FALSE
Category = Outside
ClipMode = Tower
 
[CameraDefinition.006]
Title = Top-Down
Guid = {A2849229-938A-448f-8AC6-01EF2291C171}
Description = This is the description of the map or top down view.
Origin = Center
SnapPbhAdjust = Orthogonal
PanPbhAdjust = Orthogonal
Track = None
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 256
SmoothZoomTime = 2.0
ShowWeather = No
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Outside
HotKeySelect=4
 
[CameraDefinition.007]
Title = Nearest Tower
Guid = {60BC0819-BD04-4AF6-8954-8FC8AA3545FF}
Description = This is the description of the tower view.
Origin = Tower
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = Track
ShowAxis = No
AllowZoom = Yes
InitialZoom = 8.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Tower
ClipMode = Tower
NoSortTitle = True
 
[CameraDefinition.008]
Title = Facilities Tower
Guid = {AA8C80C0-9EE2-4284-A1C2-B20CD3F5F3D9}
Description = This is the description of the tower view.
Origin = Fixed
InstancedBased = Yes
SnapPbhAdjust = None
PanPbhAdjust = None
Track = Track
ShowAxis = No
AllowZoom = Yes
InitialZoom = 8.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Tower
CycleHideRadius = 7
ClipMode = Tower
 
[CameraDefinition.009]
Title = Facilities Runway
Guid = {607C4520-CA6F-4135-AE10-8BF28838068F}
Description = This is the description of the runway view.
Origin = Virtual Cockpit
InstancedBased = Yes
SnapPbhAdjust = None
PanPbhAdjust = None
TargetCategory = Fixed
Track = TrackBank
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 1.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Runway
CycleHideRadius = 7
ClipMode = Tower
CycleHidden=Yes
 
[CameraDefinition.010]
Title = AI Planes
Guid = {75A8357E-AB58-4294-9416-90C73FAFDD90}
Description = This is the description of the AI aircraft view.
Origin = Center
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = FlatChaseLocked
InstancedBased = Yes
ShowAxis = No
AllowZoom = Yes
InitialZoom = 1.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = No
ShowLensFlare=TRUE
Category = AirTraffic
TargetCategory = Container
ClipMode = Spot
PitchPanRate=30
HeadingPanRate=75
PanAcceleratorTime=0
CycleHidden=Yes
 
[CameraDefinition.011]
Title = Multiplayer Planes
Guid = {2559BCED-9F13-4bc0-88C8-3996B9311681}
Description = This is the description of the Multiplayer other aircraft view.
Origin = Virtual Cockpit
InstancedBased = Yes
SnapPbhAdjust = None
PanPbhAdjust = None
TargetCategory = Container
Track = TrackBank
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 1.0
SmoothZoomTime = 2.0
ShowWeather = Yes
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = MultiPlayer
CycleHideRadius = 7
ClipMode = Tower
CycleHidden=Yes

Share this post


Link to post
Share on other sites

Your App Data Cameras.CFG clearly shows that the default zoom for VC views is 1.0 (InitialZoom = 1.0).

 

This is clearly different from the standard Cameras.CFG file I posted above where all VC view modes have an InitialZoom of 0.7.

 

On startup with Live Camera enabled OpusFSX is most likely selecting VC mode or displaying a default camera if you have one configured in Opus.

 

Can you please 'email' me your Cameras.CFG, an aircraft.cfg (for a stock FSX aircraft), and your OpusFSX CAM file. I will take a look for you.

 

Not sure how I am going to be able to help as OpusFSX is an obsolete product. I will try but your CFG files have clearly been altered by something.

 

As I said. The software cannot set a zoom level (not possible in FSX or FSX Steam). It has to assume the standard setup and step to the zoom level OR use SimConnect to reset to level 1.0 then adjust from there by stepping in/out.

 

 

Stephen


Understanding ...

The software cannot set a zoom level (not possible in FSX or FSX Steam).

 

It has to either 'assume' the standard setup and step to a zoom level OR use reset to level 1.0 then adjust from there by stepping In or out.

 

Hence it is possible for the sim and OpusFSX to be 'out of sync'.

 

This is down to your non standard setup. Have you been modifying all the cameradefinitions manually or installed an addon that does that?

 

I would just do what I suggested and repair FSX-SE.

 

Stephen

Share this post


Link to post
Share on other sites

First of all, I am using OpusFSI, of course. Sorry for the error.

 

I will try to play with the Cameras.CFG. Indeed, the VC is set to 1.0, which was my error after after playing around too much to find a solution to the problem. I will see if I can find out anything about the problem.

 

And no, this is a new configuration, and the only camera addon that I installed is OpusFSI.

 

I am going to find out myself what I can about this minor problem. As I said, I can zoom out after I select the camera with the key. That works just fine.

 

Thanks so far,

 

Rene.

Share this post


Link to post
Share on other sites

Just email me the above files along with your FSESERVER.CAM file.

 

Then I can compare things at this end as well. I can also email you my Cameras.CFG file and let you know what my CameraDefinitions are in the 'stock' aircraft.cfg.

 

Stephen

 

OpusFSI@opussoftware.co.uk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this