Sign in to follow this  
Noel

Do I dare upgrade beyond 3.0?

Recommended Posts

I'm still using 3.0 because it's perfect, that is until I bought the awesome Majestic Dash 8 Q400. It works fine in 3.0 except there is an issue that manifests as whenever I change views HDR disappears until I reload the currently selected view a 2nd time at which point HDR returns. This was fixed by Majestic, however only for users who have P3D 3.3 or later.

As someone loath to create problems that have to be fixed, I've resisted upgrading P3D as truly this is the only problem I'm having w/ 3.0. But it's an annoyance, the HDR issue, because I'm flying the Dash 8 a lot currently so might be willing to upgrade...kicking and screaming!

So, what problems am I likely to expose myself to if I go to the current version of P3D? I detest troubleshooting and fixing problems! I've had 3.0 installed since around Sept 2015 and as I say it's fantastic in all areas, except this one new niggle. Consequently, I never need to reinstall OS, client app, anything--I spend all of my time flying, not fixing!

I have FTX Orbx regional and Global installed, and 3 FSDT airports installed, PMDG stuff and now the Dash 8. Can I get away w/ the client app only, or must other parts be upgraded else suffer potential issues?  

 

What are meaningful improvements in subsequent versions of P3D beyond 3.0?  Right now it's hard to believe it could be any better than what I have.  Did a KSAN to KBOS in the PMDG 777 yesterday and arrived w/ 1.12Gb of free VAS, settings all pretty much maxed the entire way, and frames around 24 as the lowest during TO at KSAN, and up from there.  

Thanks!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this