chad556

3rd throttle quadrant no longer working

Recommended Posts

I've been using 3 separate Saitek throttle quadrants for years. I fly a lot of 4 engine piston aircraft, so having the multiple levers for mixture, pitch, and throttle has been nice. However.. since updating to V 3.4, I can no longer have 3 throttle quadrants active. Only 2. I use FSUIPC exclusively, and have the controls disabled within the P3D menu. I've tried everything... switching usb ports, switching quadrants, you name it I've tried it. Its not a faulty quadrant either. The one thats not working will suddenly begin to work if I unplug one of the others. Any ideas?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Chad,

Does Windows see them as separate devices? If it doesn't then it may because two of them have identical hardware IDs.

But if Windows does see them then update to the latest version of FSUIPC4 and if the problem persists send Pete Dowson the fsuipc4.log via his support forum. That will give him enough info to assist,

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now