Sign in to follow this  
MarkAJ

Aircraft loads but nothing works

Recommended Posts

I think this is a known issue as I saw it in the "Read this before posting" thread. After getting the sim to install in FSX, when I select a PMDG 747 it loads but is non-functional. As posted in the above mentioned thread, "Issues where the aircraft loads into the simulator with the screens dead and no landing gear. (failure of dll initialization)"

This is exactly what I'm experiencing. Also my control yoke doesn't work. If I change back to a default aircraft everything works fine.

So is there a fix for this? Or is it still in work?

Thanks,

Mark Jankowski

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

11 hours ago, MarkAJ said:

So is there a fix for this? Or is it still in work?

FSX or FSX:Steam Edition?

Share this post


Link to post
Share on other sites
1 hour ago, MarkAJ said:

it's with FSX Deluxe Edition on DVD with SP1 & 2.

Have you activated the aircraft? In other words, when you first selected the aircraft in the simulator, were you prompted to activate it? Additionally, did you provide the license key sent to you in your purchase email?

Share this post


Link to post
Share on other sites

Hello Kyle, well it's mysteriously started working correctly. I don't know what you mean by "activating" the aircraft when selected. There was no prompt. I usually double click on the aircraft and it loads. And yes I did input the license key when prompted.

So now I'm in the discovery phase of this new software. Quite a bit different from the original QOTS. One thing I've noticed is it doesn't like "full screen" mode. When selected all kinds of crazy graphics flashes and flicker happen and usually it closes. In windows mode everything is OK, other than the overhead panel won't show in my 4th monitor (using triplehead2go for main window). But, that's another forum search to cure that problem.

Thanks for the help.

Mark Jankowski

Share this post


Link to post
Share on other sites
5 minutes ago, MarkAJ said:

And yes I did input the license key when prompted.

^ This is also referred to as 'activating.'

6 minutes ago, MarkAJ said:

One thing I've noticed is it doesn't like "full screen" mode. When selected all kinds of crazy graphics flashes and flicker happen and usually it closes.

This will depend on your system, graphics card, and drivers.

6 minutes ago, MarkAJ said:

other than the overhead panel won't show in my 4th monitor (using triplehead2go for main window). But, that's another forum search to cure that problem.

You may want to post in another part of this forum where more people use TH2G. They may have recommendations.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this