jonss1948

PMDG 777. Ompatible with P3Dv3.4?

Recommended Posts

I realise this question has probably been asked before. So I'm going to ask it again, with Preface. I upgraded to P3Dv3.4 so I could buy the PMDG 747II v3 for it and there has been a kind of 747 400 fest around here, since. The new version of P3D seems to ignore the possibility for running earlier versions (and I've got 'em all) so the 777 series for me is kaput (read reports of incompatibility) until there is an upgrade to the 777 series. What will PMDG's policy be in implementing this upgrade or, are there any compatibility issues and can I install and activate just like before. with the 777 in this new platform?

Jon Shearer

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you updated the 777 through the PMDG control center? It works perfectly in 3.4.

Share this post


Link to post
Share on other sites
4 minutes ago, tamsini said:

Have you updated the 777 through the PMDG control center? It works perfectly in 3.4.

Now, THAT'S! exactly what I wanted to hear. I thank you for your response to my post. On too many occasions, I have broken a perfectly good Flight Sim install by installing something into it, that requires a lot of time to correct. I have done all the updates through the control centre. I really made a mistake the first time i did it  because I did the livery updates before the program updates. DUH! Anyway, your ressarance the 777 series will work is a great relief.

Jon Shearer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now